summaryrefslogtreecommitdiff
path: root/dev-python/testpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/testpath
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest2
-rw-r--r--dev-python/testpath/testpath-0.5.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index 8e10f3ffddc1..75de819e5043 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1,3 +1,5 @@
DIST testpath-0.4.4.tar.gz 92101 BLAKE2B e607fbccf66570ebe29779701bac11048751e9ee8381cd7841ba5dc55e02ee2edc32e8fd8a4a869fdd786f0c4bacdb5e7efc644e0111c24a786631257a08c9cb SHA512 4435c99325d535c713e88b59ce16704e10947232e4eccfe0e792ff9288b65e677417881ce8bbb69577aebb4b9ef793621d8e54898ecb158d07fc22e8445950e2
+DIST testpath-0.5.0.tar.gz 93168 BLAKE2B 864ac80e027192fb1a83f1a15db55fe72729154c7236f2054abfe161be36741614732efbea2a6b4eeb1fb59befa36002d767b4113fab98202ff22330ad15e21d SHA512 d960da04b490b355c5ca9d8e348d81a0d528f13dc7a2b5d6d3c09327a603c1582bce76f7de6d1666b490112306a10d6a19c7979c1119fb726c08c712a08bbcb0
EBUILD testpath-0.4.4-r1.ebuild 722 BLAKE2B 502726ac5906bed17a14903d206235d0d0b3ed9f39ffaa8eba88433cd19f67b2682d97200358f2819948f9066895b4a25628f4bb547fd925c7b16612ea8f3ebc SHA512 bb11c35555a6694564774daf6ea6bf0bc772e4e646b2bca1068c3a6615a8b4d3faeffb127825c4b006245a3295c0138254e09494979cc39e3fcdae1722c87e0b
+EBUILD testpath-0.5.0.ebuild 766 BLAKE2B 2cd2aabc9f6408f712ba7541df3026626ed0d826d0b0d27792d396b3aac8d69c76f64a9808f932ec34a5c73bcfe630245ee887dadd5c577a5e933548786fb778 SHA512 f4dd5038626c2cb01f5146996bb972c6db1c83bf0e0d15509392f5d1b144e8f05c7de811f04d965ddc48dc1925c8900c0e25abc16a0e3c8dcdd5e243b591a689
MISC metadata.xml 764 BLAKE2B 66ca0cbf31a2ae4f9e59e232c029f530b9b6fb5d6d53c9a3a4fd69293a987f3a46c6530e20a9c4cca4056a91b546062b9aa2135d537de276255ae6188633257d SHA512 7787d485d68e575b8a0e01dd20bffaa317c8168a1dfb38cab9c6bdbe80778131e9ac1bb8dee91bcf6ee91de5ec466027f7b1fdcd65d5fbd81dc8433804e3f3d1
diff --git a/dev-python/testpath/testpath-0.5.0.ebuild b/dev-python/testpath/testpath-0.5.0.ebuild
new file mode 100644
index 000000000000..44cf89905b50
--- /dev/null
+++ b/dev-python/testpath/testpath-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-15
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc