summaryrefslogtreecommitdiff
path: root/dev-python/theano
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/theano
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/Manifest2
-rw-r--r--dev-python/theano/theano-1.0.5.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index 9370605fba9f..7fe67bdeddc6 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1,3 +1,5 @@
DIST Theano-1.0.4.tar.gz 2840691 BLAKE2B 7f89caee3dd50d75ff09693fde7926f2b7da0f94758ef932f207feea29d74d38ed56591e6ebe0b46cfa043d5fb46d5b97028171acdfd324a01eb7b904169b4ac SHA512 3cc7f9dbb606c3c997c8651c34dd861721d5a8b99d06ed0887306d5a5ad0d7e402fbe29dcb5ad2f513b3bf75966e41a2854ebdf9a4fb212607345f84f367de8c
+DIST Theano-1.0.5.tar.gz 2842778 BLAKE2B ee82e9487a5265a1040750ace70465c450134e70eba4e58752cbaa7d487be5fb3cce31b838429cb52f7bc31d32a20379e158ee289dd5732dd8b86a9ee36b6d89 SHA512 6bb27753957d32392ea793e39ea56eff94baafbb55e27488f9c0bbdb387172a6829e64f461f83dae192486d9764b72d815e3b8dc059b2af116b024fc7228a118
EBUILD theano-1.0.4.ebuild 1257 BLAKE2B c7fef716786c92810df145f74debd9cfef52b81028a532f4b111e4ec5317e3d57c4e5d1ab885d6dec8ecd323e43fd6227c6399bdec46345e098a656961a83a44 SHA512 fab62809f565ca9ee4781b9d605e5f176962b76c02ae07c5fdc299fd7cddfbff26bde88fb8c4afc00f26cfd6c4eaa930becd12c8483b8e69421c08f4af1d0b7f
+EBUILD theano-1.0.5.ebuild 1070 BLAKE2B dd446d06b3db9a27950063c572da4eb4f1e8d9ddd85d7396bfda5d7f26446e9d34ec6eaf14c4b33e867cce6ce4a0190ac3c4f8d3c3102ff57a9923d97e103a65 SHA512 38a07dcfe32b33ec801f7302c325982d438d2a07a4067160aafb9913f2c834ff21bfdca6b4c20c22726c1fb8c599c22610872b53e3f71159a11c811c86e74377
MISC metadata.xml 632 BLAKE2B 2bee1d4912596b45d3f5cc0528a927078a072091148dfce38892319b91a0635859fa91dea32565b4a7f5ed02726364a50870bab22197c57ff33c88a48ad9d223 SHA512 653fc6d180455ee24967e70f78682ed2a7e61022d6867390b4c4eb994699b3f293bafe45b4fcf1c4ace3f102acba41c5491e8fb39b9f6102f1022a2c51955ef7
diff --git a/dev-python/theano/theano-1.0.5.ebuild b/dev-python/theano/theano-1.0.5.ebuild
new file mode 100644
index 000000000000..6bee991692fd
--- /dev/null
+++ b/dev-python/theano/theano-1.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils
+
+MY_P=${P^}
+
+DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
+HOMEPAGE="https://github.com/Theano/Theano"
+SRC_URI="mirror://pypi/${MY_P::1}/${MY_P%-*}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="test? ( dev-python/parameterized[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e "s/, 'flake8'//" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ nosetests --verbosity=3 -e test_format_flake8 || die
+}
+
+pkg_postinst() {
+ optfeature "Make picture of Theano computation graph" dev-python/pydot-ng
+ optfeature "Required for GPU/CPU code generation" dev-python/pygpu
+}