summaryrefslogtreecommitdiff
path: root/dev-python/theano
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
commitf660c6de84558324d784218831d8f0782ee41e2e (patch)
treec1f2aa79617d0ceaaff49d71603abc386aae2c37 /dev-python/theano
parent95461df035e3867364495f065e5e805bf629b2d7 (diff)
gentoo resync : 27.10.2021
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/Manifest3
-rw-r--r--dev-python/theano/metadata.xml17
-rw-r--r--dev-python/theano/theano-1.0.5-r1.ebuild53
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
deleted file mode 100644
index 5fb4f6c56987..000000000000
--- a/dev-python/theano/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST Theano-1.0.5.tar.gz 2842778 BLAKE2B ee82e9487a5265a1040750ace70465c450134e70eba4e58752cbaa7d487be5fb3cce31b838429cb52f7bc31d32a20379e158ee289dd5732dd8b86a9ee36b6d89 SHA512 6bb27753957d32392ea793e39ea56eff94baafbb55e27488f9c0bbdb387172a6829e64f461f83dae192486d9764b72d815e3b8dc059b2af116b024fc7228a118
-EBUILD theano-1.0.5-r1.ebuild 1391 BLAKE2B 56b7f16fdac45bfd888c0b6a415036c80514eefa420f42fb457335db51b9c267d8b8d783d9bb66258f707f2c3fae754457314a46599eaf0e3134a626faf40762 SHA512 59e314a4bcb93334081df3cee79bccfde90bfe1bbe0e426f36828f70b1155ac376a7c789088693c070ec6e1da0032c04a29e2e3aee0690c7fd1e3a89f65c95a6
-MISC metadata.xml 633 BLAKE2B e8efac228689fae8bd3730798964dcfe8a9b7a96bd0a7315b348d6c555d26242455c20630c3e3a6d2635af1f1b4c8070eef491b9b56252abb491c66dced54554 SHA512 d01be9e54f1ecf45537346e964fb9e7945e31cfe089823d8306d3edf298802f361bd56e3903a93bab5a85e10aceeaf53a6d15d8c75e0c091c5e18dab119cec73
diff --git a/dev-python/theano/metadata.xml b/dev-python/theano/metadata.xml
deleted file mode 100644
index 8c2b5f739e23..000000000000
--- a/dev-python/theano/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Theano is a numerical computation library for the Python. In Theano,
- computations are expressed using a NumPy-like syntax and compiled to
- run efficiently on either CPU or GPU architectures.
-</longdescription>
- <upstream>
- <remote-id type="pypi">Theano</remote-id>
- <remote-id type="github">Theano/Theano</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/theano/theano-1.0.5-r1.ebuild b/dev-python/theano/theano-1.0.5-r1.ebuild
deleted file mode 100644
index 88af2c3b4844..000000000000
--- a/dev-python/theano/theano-1.0.5-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 optfeature
-
-MY_P=${P^}
-
-DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
-HOMEPAGE="https://github.com/Theano/Theano"
-SRC_URI="mirror://pypi/${MY_P::1}/${MY_P%-*}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-# Tests sometimes hang. dev-python/theano-pymc is better. #738416
-# This package is on the way out anyway for that fork.
-RESTRICT="test"
-
-BDEPEND="test? ( dev-python/parameterized[${PYTHON_USEDEP}] )"
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-
-src_prepare() {
- sed -i -e "s/, 'flake8'//" setup.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- nosetests --verbosity=3 -e test_format_flake8 || die
-}
-
-# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
-python_install() {
- rm "${BUILD_DIR}"/lib/bin/__init__.py || die
- distutils-r1_python_install
-}
-
-pkg_postinst() {
- optfeature "Make picture of Theano computation graph" dev-python/pydot-ng
- optfeature "Required for GPU/CPU code generation" dev-python/pygpu
-}