summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
commit16a4365c3b854e62b50726456ddb29bb78fd5038 (patch)
tree6de11adc70daeb6424485bb16be162d2cb277018 /dev-python/threadpoolctl
parent59d772d9463f8cf6a145a677bedbf377a0625aff (diff)
gentoo auto-resync : 15:12:2024 - 02:02:03
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest2
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild52
2 files changed, 39 insertions, 15 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 40c08546308f..e6899f0774cd 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,3 @@
DIST threadpoolctl-3.5.0.gh.tar.gz 37417 BLAKE2B 56b175afb96ce824286f42d0384c158823460b15f66c56b9b904c99e258629ed892906a16f15c3626908c293d25879cc0ca114d0578b1daff3610c2e9b38a3ed SHA512 6b24a6b3df3104b4222df5a20a8c7e321753dfa9ab0df872345a715d5f9ced2a577fe0d730dc4fd382e0ecfdb91a244eb28ba0b831d5db5af98f246f8f56228d
-EBUILD threadpoolctl-3.5.0.ebuild 1177 BLAKE2B fb47daeebcda5497894aa622826192deb12f195a6579dddd6de6e1717530cbd5f8e1d7cb0c507e82f264f6538c26ad8362107a6a494aca5bfcd8de91ff9017b7 SHA512 eca64061a3fe14bcfa0c0a9d10575225aa1a816d514ff5712fd03c072a40376f095a2310aa81c0e0a7ce2d3544df1f4790814287f740d7fceab8474bd356a0bd
+EBUILD threadpoolctl-3.5.0.ebuild 1939 BLAKE2B 689869b03ee7330b52896bce96211f0d20040ec83a3401ea911e1bf096df633b6cb952244925a22d74446dd9e6d0d91a3490b9574b10ce1256083ba210c81872 SHA512 52991ef84cd7eede9af59d5600b33bd1b29aaaa36cfe53b8c935abac0bffb02ffc69c47db4ea23d27691bdcc0875be3b6c12e18ddf68898853f56392ce3b798d
MISC metadata.xml 489 BLAKE2B eba7a68832688f4c6cca1f30e188bae378c82347d87d7a0186fe3821dd04b75fdda2a7826785c3a59eda7362d1119d183be239b06c90ce14096e5a87459d2a29 SHA512 e14a5317dcfb8506a277d358ec227d276cf148e0293fc56b14751804a89fa20134b5be752fcc8beaffd12e246722d34120449a8f1ea0900e2918e42889c54dd8
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild
index 6ca8d30b9588..683fd2c02468 100644
--- a/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild
+++ b/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild
@@ -4,9 +4,9 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
HOMEPAGE="
@@ -23,19 +23,43 @@ SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # Asserts against a hardcoded list of CPUs. Either we skip it
- # or file bugs about missing architectures until upstream realizes
- # how bad idea that were.
- tests/test_threadpoolctl.py::test_architecture
- # This test fails if the Python executable (or any library that it
- # links to) uses OpenMP. This can particularly be the case with
- # CPython 3.12 that links to app-crypt/libb2.
- # https://github.com/joblib/threadpoolctl/issues/146
- tests/test_threadpoolctl.py::test_command_line_empty
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+ # This test fails if the Python executable (or any library that it
+ # links to) uses OpenMP. This can particularly be the case with
+ # CPython 3.12 that links to app-crypt/libb2.
+ # https://github.com/joblib/threadpoolctl/issues/146
+ tests/test_threadpoolctl.py::test_command_line_empty
+ )
+
+ # see continuous_integration/build_test_ext.sh
+ if [[ ! -f tests/_pyMylib/my_threaded_lib.so ]]; then
+ pushd tests/_pyMylib >/dev/null || die
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o my_threaded_lib.so my_threaded_lib.c || die
+ popd >/dev/null || die
+ fi
+
+ pushd tests/_openmp_test_helper >/dev/null || die
+ "${EPYTHON}" setup_inner.py build_ext -i || die
+ "${EPYTHON}" setup_outer.py build_ext -i || die
+ "${EPYTHON}" setup_nested_prange_blas.py build_ext -i || die
+ popd >/dev/null || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}