summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 05:36:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 05:36:35 +0000
commit4a480f0f8da23a70c88c65a5c218926670f5a870 (patch)
tree2abc6251159b381d83839759b7e497a4f1ef0569 /dev-python/threadpoolctl
parentdbcb48dedd80e9453883ed9e0b0ed4561a534e57 (diff)
gentoo auto-resync : 15:02:2024 - 05:36:35
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest2
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.3.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index cf88eccda93f..358d9932d390 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,5 @@
DIST threadpoolctl-3.2.0.gh.tar.gz 32196 BLAKE2B 662b2ab6908719c11881dbaba00437b049f71dc8b6c5c8f4c3733cd156312a6410eca19d0446e11cfaddd039261adb25398a3827e822584ad52b428e67fc6b17 SHA512 01017047ceaa353239fea5410be3b6cd924068d7e18a80bc04cc07f08341e3405fa8620a8e5f43f16b674a3ce535d15e42b41741f78079fb61e618c8b9d1583d
+DIST threadpoolctl-3.3.0.gh.tar.gz 36189 BLAKE2B 0c51d10d2444e76d8c1e46dc60e8434e515c56919b2e276261a5c595db38c5ecf35fda88308d4e2d50e5a03a2946a02fb7c15ecc3224d734bd6f1ab0e7af16f4 SHA512 901ab53aa30b3931b08f89eb1439517883f05762032e924d4bbcbf19a2ffc145b10fc65817199a9a3a7c5cf2ad38860d3b0df6b9d3b83fd24799804671c01524
EBUILD threadpoolctl-3.2.0.ebuild 1169 BLAKE2B bfc53422030326b8d7e1ad0fd95e65504bf9401d007aee2531f021af7aadc8ebe8148ad832500340591ac791f91e6fffe2911cd909872dd0ccb48fc67fd702d7 SHA512 244d872563c09e6727828e750c2e1875d8a2706073d3a3fbeb27001b232384713b620511d70f4ad99deda0d380a21fe678b52a56dcbab728e57473164571922c
+EBUILD threadpoolctl-3.3.0.ebuild 1181 BLAKE2B cb19362d837d4e38024c5aa996e0a110e36869138f973bade4c7f1b348f650bb893c1a88178c878e9f067c85fa2b9e84508486690a93ce8bd1b9da9a18131a2f SHA512 fff40f09d60f2c00f1f698ad52ade114c78af08595201012822c0243a9937ac93eb87b0050d6e5d9e48923446b32f49dfbd9842d45de20316d311a6b0fd29132
MISC metadata.xml 489 BLAKE2B eba7a68832688f4c6cca1f30e188bae378c82347d87d7a0186fe3821dd04b75fdda2a7826785c3a59eda7362d1119d183be239b06c90ce14096e5a87459d2a29 SHA512 e14a5317dcfb8506a277d358ec227d276cf148e0293fc56b14751804a89fa20134b5be752fcc8beaffd12e246722d34120449a8f1ea0900e2918e42889c54dd8
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.3.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.3.0.ebuild
new file mode 100644
index 000000000000..88092a680ad2
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/threadpoolctl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+ # This test fails if the Python executable (or any library that it
+ # links to) uses OpenMP. This can particularly be the case with
+ # CPython 3.12 that links to app-crypt/libb2.
+ # https://github.com/joblib/threadpoolctl/issues/146
+ tests/test_threadpoolctl.py::test_command_line_empty
+)