summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/thriftpy2
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest4
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.5.0.ebuild14
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.5.2.ebuild14
3 files changed, 4 insertions, 28 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index 1accb596060e..a9c562b9dc49 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,5 +1,5 @@
DIST thriftpy2-0.5.0.tar.gz 779019 BLAKE2B b29e5349e11e3ce3bd587a7c8212cd6def7b9b287554a068399591bb7493a5c1d0e97c9b38a64973c01d27a83d49e181aad64cb41ce9500e40b96c813caa7b2d SHA512 f4c83bac053a2f073507e38f284f981bd129ee960dc9817f3bd5795c8e9773b78fa23d49d97cb5975783dbd1f4b52f380861bf4fc32a1af795365f703856f350
DIST thriftpy2-0.5.2.tar.gz 782261 BLAKE2B 657e8dadd8757f9f0f6b4a7f73e4347651f6301c969cf4d2c37cf87c6176322b7afad6372a39ed7d4c9f36d07850d6ae4edb73ff08dd3530b88e0194032abc9b SHA512 89a73d70b7ba74acc5344c1471587a66664331fb3d160eeb31d27434c78a3e76e3ec0d84dec14ec57d0bcc89e867759883d69247ae65bff1a9a8a00fc8ff7747
-EBUILD thriftpy2-0.5.0.ebuild 1138 BLAKE2B 080b8307a9e3fb92edab9e2829cc15bde7197409f0adbba4698e3e52ebe4d3723ffc755cf5b2df2a471592d6aa00da7eb98fd06b0e113ee70564b403debfdd1b SHA512 226d615f96f2a862f371335acd1cdf676d7e3f9826885ee7e9ac2fb6090d6faa38114e50a7e0263f20fe63db16fb6d1298e08f58ef6f5fd6ad51443d8b2004d6
-EBUILD thriftpy2-0.5.2.ebuild 1194 BLAKE2B 4f40986873dfd76740b8477e87794513e0c8da39ced43acd1242cbb91222285801986a53e4736a540df600608d3fd243497e63c80006038a8aa52eda9e3b2b7f SHA512 28e154389f329ee057b52f38817066c695d92b79bdef0436c83a9a29a56708d5eeac645a6c270419f4af22e483e4614b530ddd16d956a0cf5012e45d28db045e
+EBUILD thriftpy2-0.5.0.ebuild 889 BLAKE2B 386dd3f0ae5f085dcd302b34d3edad04a6098d4d0444ac310548bb36e728945b2e5986e69c304d8bf589df5e948874729570de9a2dcec4fca243d02836636bc5 SHA512 f3c69786a4c1d0193e69b3e1c96a10b642e914302e856890ec3d161a6dd405cf4841a60c58aabb8779a86a1c853aeea9f2eab0bc359c1cd1adbbbcf8d28a7463
+EBUILD thriftpy2-0.5.2.ebuild 945 BLAKE2B 57dbdaaad391744f022b2e86b8f6d445108fd50e72aa3ee809c826da786929283cd862261750de48b0b795cfe336bf97fe96489542ad5c751a4e1fdfe850d53c SHA512 bd12f197571dc64a2044458e4b52b87586eb8265400d2ea202cebe2158060d30bc70d20af9b1dc7a2d7fddf1c316ef095d386b38b5abfc3727a6047bef418e9e
MISC metadata.xml 481 BLAKE2B fb00a720771ef2adfabfd3c2f9ecff88c263694947e1e457ab935cd2aa788b4879274857df7a898ad9e58239ce5de8f701febf148b1e2fd183330eba4e05f411 SHA512 86d6a43672be2259890e14f6ebe6bdb8645db7b9eda2da86b92546fc995cdafd767fedbb9c1998be3c062b95ed03d6ab28df4e8028ffc907b31eb423fc553fa6
diff --git a/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
index 53fdb44f8d8e..3795d532cc5b 100644
--- a/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
+++ b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 flag-o-matic pypi
+inherit distutils-r1 pypi
DESCRIPTION="Pure python approach of Apache Thrift"
HOMEPAGE="
@@ -33,18 +33,6 @@ BDEPEND="
distutils_enable_tests pytest
-src_compile() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/857105
- # https://github.com/Thriftpy/thriftpy2/issues/246
- #
- # Don't trust this to LTO
- append-flags -fno-strict-aliasing
- filter-lto
-
- distutils-r1_src_compile
-}
-
python_test() {
local EPYTEST_DESELECT=(
tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
diff --git a/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild b/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
index b045d0f08da7..96c5e972bc59 100644
--- a/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
+++ b/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 flag-o-matic pypi
+inherit distutils-r1 pypi
DESCRIPTION="Pure python approach of Apache Thrift"
HOMEPAGE="
@@ -34,18 +34,6 @@ BDEPEND="
distutils_enable_tests pytest
-src_compile() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/857105
- # https://github.com/Thriftpy/thriftpy2/issues/246
- #
- # Don't trust this to LTO
- append-flags -fno-strict-aliasing
- filter-lto
-
- distutils-r1_src_compile
-}
-
python_test() {
local EPYTEST_DESELECT=(
tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception