summaryrefslogtreecommitdiff
path: root/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/thunarx-python/thunarx-python-0.5.2.ebuild')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.2.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
index e6c360683a7f..20f6bac54822 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1
@@ -13,18 +14,23 @@ SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
>=dev-libs/glib-2.30:2
>=x11-libs/gtk+-3.20:3
>=xfce-base/thunar-1.7.0
$(python_gen_cond_dep '
>=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
src_install() {
default