summaryrefslogtreecommitdiff
path: root/dev-python/thunarx-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /dev-python/thunarx-python
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest5
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild34
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.4.0.ebuild33
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
index e44dd0d7e414..b86a4debb505 100644
--- a/dev-python/thunarx-python/Manifest
+++ b/dev-python/thunarx-python/Manifest
@@ -1,3 +1,6 @@
-DIST thunarx-python-0.3.0.tar.bz2 303035 SHA256 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258 SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f WHIRLPOOL cfcf986b7ca9bc2fd50d4d5bbb80c6df7ac557e3ca15703eada5c71a302d4275cee7972d13cb3d746e064caeb9e90f366819045bc109d761bcc898ce5a70d577
+DIST thunarx-python-0.3.0.tar.bz2 303035 BLAKE2B af0193a3bc97c859ba98f52c612d5af81c5b7a0d8142a8283cf2b308fa183ac57ac1a2163cd882749b6fd33e0529f20f1f9e2db2dcc1aed26cb40cd5995780fb SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f
+DIST thunarx-python-0.4.0.tar.bz2 332620 BLAKE2B 768a2a236e12d298efb3abc86f4a339548248f5f88366ec7d956249c028474612b15c340976ac2c2ced806a89517278c70b50069d76b2eee6af6dd097789e275 SHA512 fb54f83c11857ec2236a249895954efc29446120c192b8d19794b7e8145836969f87d1efa524bfaa4c9d31ee08a2c17a57d7210ce4a3a4982780d128839d02b1
EBUILD thunarx-python-0.3.0-r1.ebuild 945 BLAKE2B 6e21b84d4696ef1a37125ffe6faf0a99747d4a86a4e8632fd46c567240dba91500d7dfe1fc2248e454f0451cda3de091efd5551b3be7115facab3cbf5d4d9ab0 SHA512 aedb93000543f01385a0044f5c1af7b95240bb7131c6239e1297f31ef3a8d8b23c271d1011371c603c260f26b5c46eb4eb519377441f646cbbd4a187b1201781
+EBUILD thunarx-python-0.3.0-r2.ebuild 772 BLAKE2B ae1189ce1ed8d56f8f88d260913451c21a8e74942fa6239cb1545148f6e773b3eb0ef488c64ecf4114bbbb81af6e76d118af2d4ccf84f903a2c7187841a7d94a SHA512 b07942f687325fad89861bcc745623d2e8cc23a0bcc087f5a56924780bac33127af57069d02f8f24cb138a7f7422966c68fffe1a6dc143b1b65089dd304dc83a
+EBUILD thunarx-python-0.4.0.ebuild 753 BLAKE2B 271f58f98f3b0487625d72e037cd5fd6470ca5fc282ad510e89e75e9fbb970101faf830c0801be1b3113e0bc7cc6b99eb07fd0d6195a267d45029e79727bc403 SHA512 c054426c2f48de127413768a92774c8da2ead3a66c111863e71b7a14853190b3af7bae4d33db26aac18e0d935bfc86c78c05392e4834f5f9ad6fee19b7997f72
MISC metadata.xml 357 BLAKE2B 48cf41f710ba774f8adaea9825d2b72803e19e55a76afea97cec934449c0723d7ca411ee20297652179abd621bd6bbf533aaed3ebe0d6601b13ad26840d225c9 SHA512 f707818cf1217c314e8c0a18c990f4b1e65b358e7fefe68490d59956c97aa40a2f2b0130d89a54a658dc2caea11e0c5a01f04553faab53dd32513bc299e90b58
diff --git a/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild b/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..437e445d932b
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.1.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild b/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild
new file mode 100644
index 000000000000..5f2803170adc
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/glib-2.30:2
+ >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}