summaryrefslogtreecommitdiff
path: root/dev-python/thunarx-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/thunarx-python
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest3
-rw-r--r--dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch85
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild15
3 files changed, 95 insertions, 8 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
index 5ea6930f703d..18e7da58aa4f 100644
--- a/dev-python/thunarx-python/Manifest
+++ b/dev-python/thunarx-python/Manifest
@@ -1,4 +1,5 @@
+AUX thunarx-python-0.5.1-fno-common.patch 3161 BLAKE2B 5af487237d518c08a068b592000c4dfffb9e63f4004ed691343d446058adf070bd1d7710c6eb740dfa6602726bfe53f59309a4ac5991c74b46206f6d076c1977 SHA512 501faf134750e07584b0464c1881934fc881cae888bafa4e53afd56f34f1d10a34cf1d90bb39955bc98bd9b0d804cd0a5f636b68f34c8e935860b1019d8cb059
AUX thunarx-python-0.5.1-py38.patch 951 BLAKE2B c83f78b4ddbd08b7325d87b16133ee455b43a8e7c666661b15a582ec96eaa6a81c0a0b1ee19b4428b06e60ac1ce04414c3ed5f754c037cf17223081aa2ddf49b SHA512 44cc2aeb13e8d98ce2e9cdd0a28906da3d9826080b12b33ee7cf78e80f57371a0af801df8ba9967b5d831bb442c5836f02427b7ee58045c2f326dbcf3808508b
DIST thunarx-python-0.5.1.tar.bz2 334426 BLAKE2B 59f8e625b10ceeaefffa4b6dde150c32023365e76854c6e77ae2f222b509856353c8d62de26ba4e7b967cfcce1219205923938389fd1714a420bc9e1ac2b12b2 SHA512 0c1d8f20b74a3eb87b3c2c181c6438bc059dff75afdc26cfea19dffb7efe1f14e6a880689f73afcbbcb5922312741df72018e3b9980c4a45426e7a7d4651177f
-EBUILD thunarx-python-0.5.1-r1.ebuild 804 BLAKE2B 5445bf968f9bb1f152f464cfa835ea882418e41151c9338343bf976e813127290f384fa3b1f0558b09e587b522395fc4ba3ccc8ea55d52ae59e78d8d7210c408 SHA512 8c0381b21508045a2665d962ba875fa9c4a133afd0d3ed26ff84861951081c272d0181f1884c6268677f0d11881fc2c6d54f0713f7e62b8d3c12e7fbf0263bc3
+EBUILD thunarx-python-0.5.1-r1.ebuild 843 BLAKE2B d80e670bdcae81ba6385c974556100e53c389f247e1c7e163de95e75559ffd76beb16ea73d45ce186c48920323d21fea442a9c1c0ef03c5c00560483d9766a22 SHA512 6d7fb1027fb3655b669b2e8a8b937e6bb0b765ec68030fcdb461f77fcd878e0dfcb2638f1f3cc9d00152dd06dfbbaeee798b82259686bba9979270974f37d6bd
MISC metadata.xml 249 BLAKE2B cfb34e0ab5b7155d26bee3e5cc55d570e05151273d6793455b82980b3e3411983eaee6a6ea94f896b18df24efdc964f180bb00b3852a98a2cc5571f1d22f6d84 SHA512 ec9e5427d44f20c2c0166fe103e6e8b8384a300685f7c9774f9177a1533d7057f332af1ba1046462f75bb3f2812e075d01b5eaeb625340c911d2bc6d2f9acf7c
diff --git a/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch b/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
new file mode 100644
index 000000000000..21f55c0e6f8e
--- /dev/null
+++ b/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
@@ -0,0 +1,85 @@
+Taken from: https://git.xfce.org/bindings/thunarx-python/commit/?id=3037ebe25d5c6ed58699e56b61f657cea3e5a5a6
+Author: Mukundan Ragavan <nonamedotc@gmail.com>
+
+--- a/src/thunarx-python-object.c
++++ b/src/thunarx-python-object.c
+@@ -24,6 +24,7 @@
+
+ #include <thunarx/thunarx.h>
+
++#define NO_IMPORT_PYGOBJECT
+ #include <pygobject.h>
+
+ #include <string.h>
+--- a/src/thunarx-python.c
++++ b/src/thunarx-python.c
+@@ -30,6 +30,18 @@
+ #include "thunarx-python.h"
+ #include "thunarx-python-object.h"
+
++PyTypeObject *_PyGtkWidget_Type;
++PyTypeObject *_PyThunarxFileInfo_Type;
++PyTypeObject *_PyThunarxMenuItem_Type;
++PyTypeObject *_PyThunarxMenu_Type;
++PyTypeObject *_PyThunarxMenuProvider_Type;
++PyTypeObject *_PyThunarxPreferencesProvider_Type;
++PyTypeObject *_PyThunarxPropertyPage_Type;
++PyTypeObject *_PyThunarxPropertyPageProvider_Type;
++PyTypeObject *_PyThunarxProviderPlugin_Type;
++PyTypeObject *_PyThunarxRenamer_Type;
++PyTypeObject *_PyThunarxRenamerProvider_Type;
++
+ static const GDebugKey thunarx_python_debug_keys[] = {
+ {"all", THUNARX_PYTHON_DEBUG_ALL},
+ };
+--- a/src/thunarx-python.h
++++ b/src/thunarx-python.h
+@@ -43,37 +43,37 @@ extern ThunarxPythonDebug thunarx_python_debug;
+ #define debug_enter_args(x, y) { if (thunarx_python_debug & THUNARX_PYTHON_DEBUG_ALL) \
+ g_printf("%s: entered " x "\n", __FUNCTION__, y); }
+
+-PyTypeObject *_PyGtkWidget_Type;
++extern PyTypeObject *_PyGtkWidget_Type;
+ #define PyGtkWidget_Type (*_PyGtkWidget_Type)
+
+-PyTypeObject *_PyThunarxFileInfo_Type;
++extern PyTypeObject *_PyThunarxFileInfo_Type;
+ #define PyThunarxFileInfo_Type (*_PyThunarxFileInfo_Type)
+
+-PyTypeObject *_PyThunarxMenuItem_Type;
++extern PyTypeObject *_PyThunarxMenuItem_Type;
+ #define PyThunarxMenuItem_Type (*_PyThunarxMenuItem_Type)
+
+-PyTypeObject *_PyThunarxMenu_Type;
++extern PyTypeObject *_PyThunarxMenu_Type;
+ #define PyThunarxMenu_Type (*_PyThunarxMenu_Type)
+
+-PyTypeObject *_PyThunarxMenuProvider_Type;
++extern PyTypeObject *_PyThunarxMenuProvider_Type;
+ #define PyThunarxMenuProvider_Type (*_PyThunarxMenuProvider_Type)
+
+-PyTypeObject *_PyThunarxPreferencesProvider_Type;
++extern PyTypeObject *_PyThunarxPreferencesProvider_Type;
+ #define PyThunarxPreferencesProvider_Type (*_PyThunarxPreferencesProvider_Type)
+
+-PyTypeObject *_PyThunarxPropertyPage_Type;
++extern PyTypeObject *_PyThunarxPropertyPage_Type;
+ #define PyThunarxPropertyPage_Type (*_PyThunarxPropertyPage_Type)
+
+-PyTypeObject *_PyThunarxPropertyPageProvider_Type;
++extern PyTypeObject *_PyThunarxPropertyPageProvider_Type;
+ #define PyThunarxPropertyPageProvider_Type (*_PyThunarxPropertyPageProvider_Type)
+
+-PyTypeObject *_PyThunarxProviderPlugin_Type;
++extern PyTypeObject *_PyThunarxProviderPlugin_Type;
+ #define PyThunarxProviderPlugin_Type (*_PyThunarxProviderPlugin_Type)
+
+-PyTypeObject *_PyThunarxRenamer_Type;
++extern PyTypeObject *_PyThunarxRenamer_Type;
+ #define PyThunarxRenamer_Type (*_PyThunarxRenamer_Type)
+
+-PyTypeObject *_PyThunarxRenamerProvider_Type;
++extern PyTypeObject *_PyThunarxRenamerProvider_Type;
+ #define PyThunarxRenamerProvider_Type (*_PyThunarxRenamerProvider_Type)
+
+ #endif /* THUNARX_PYTHON_H */
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
index d2bb115a4a8c..08d8b303c2db 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
inherit python-single-r1
@@ -13,21 +13,22 @@ SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="${PYTHON_DEPS}
- >=x11-libs/gtk+-3.20:3
>=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/thunar-1.7.0
$(python_gen_cond_dep '
>=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
- ')
- >=xfce-base/thunar-1.7.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
REQUIRED_USE=${PYTHON_REQUIRED_USE}
PATCHES=(
"${FILESDIR}"/${P}-py38.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_install() {