summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-python/tifffile
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2023.4.12.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 6c2fce4d3081..c50fe115863b 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2023.3.21.gh.tar.gz 331285 BLAKE2B ce63dc2f389d3e93cf50c52efe849423c091bdf048ce7f408fe6ee4556da4b9efcbaa031e7bc7f2b3f953117f7ce18014d1a77f9253a82d6dc4352464cf4151d SHA512 68b90d7eab293991b0227090d5b4c047469cd65c339f8d19da68097d99640c7f45cf8746eac4b3da9a388a58cd4343bbcad25496b08c13c913e48f982e14f5b9
+DIST tifffile-2023.4.12.gh.tar.gz 332954 BLAKE2B 357e691a0b551eb1ac5349bcc8a7168399e93c82353f5da5d95953142f206388da876e16f6948937ed9fb36128eaa4c3999c6fca494a9d5466894b5324c1cdcd SHA512 3a5c2ed6beaaf0f1c7f4dced0f57eab1cbd1f23040df8c701ffac8569b6fbdcebd71b6970e9c6911c1fd501add78880d8102c8476126007472fcdb82c9628bcf
EBUILD tifffile-2023.3.21.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
+EBUILD tifffile-2023.4.12.ebuild 1728 BLAKE2B 09954d2fe721c35ebbc5603c877244d95392e7764da8cfd0960a4a668d14752483973e7e686ac818711e5e5857bfa199695e6896d751cfb3c3de4f6fb3d94d8e SHA512 0268394f8d3a53a7aa618a75063654acc19e14bf731436a3a5ba1e8e3c96d092f0bd23a761113b4e9b13377ebde7d379a38515fa8446742bffccdfac0ffc2b7e
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2023.4.12.ebuild b/dev-python/tifffile/tifffile-2023.4.12.ebuild
new file mode 100644
index 000000000000..9f7bae8eb48b
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2023.4.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+ # missing private marker
+ # https://github.com/cgohlke/tifffile/pull/195
+ tests/test_tifffile.py::test_issue_invalid_predictor
+)