summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
commitbb262580ec0b56a32797f121e627928d103e6bb1 (patch)
treeb3b80cb753a087635c972352ce99fed1d01f286b /dev-python/tifffile
parent35e3ee5faf74dc69409f957f81a6848d4d24c49f (diff)
gentoo auto-resync : 30:12:2023 - 23:46:05
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2023.9.26.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index c3d592528880..78928e525728 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,5 +1,3 @@
DIST tifffile-2023.12.9.gh.tar.gz 343750 BLAKE2B c6f3ae05870bbd3fbf67915b2d88ad6662362c28842412449510df8162dc1eb0fd52adb322c4d163c5c3bbc61c182fde08bc38d7b7a4cf6df5554d8e89e6b6c9 SHA512 de51d75cff08f617d638dbd062940ddcd2b0a0ffb25d4670e8d68bd8bcf19ff299695d7b0c8248d5405bfb0015c539b3dacb5133816eace7d0e93cff4f0d2c00
-DIST tifffile-2023.9.26.gh.tar.gz 342486 BLAKE2B 034013769c67b3e90bcfdf8b054419d00d35601603d716fa8cc37974cc37a4eabd773983047ad2cfbebfe4b15d7268defcad8f8d69f780af3a47299a52cbadf1 SHA512 ec59c408731143b60cc7664ab038ae885c21400771b0673828bbd07a46c7faafd503c1cedafbd08aaabfde554d2e42664a6f8f2ae753fc4405a9c98f8c2b8e1b
EBUILD tifffile-2023.12.9.ebuild 1687 BLAKE2B f092eeafc23287e5964607c049902aad2f0e7b3f7068c29ba7c24071c0e62b59c5a6d8418e11acdbd155c75de2af6003186014a4df03ec650bb940e542a96352 SHA512 adb80e2f78781bc88dbef27ccf7cf20eeab057ef458f0e9b4c4c89f70c16ffebd413b53679effe580dde29a97d8e3013fd2efa1f5b2d36627324fc6d1e90dc8f
-EBUILD tifffile-2023.9.26.ebuild 1687 BLAKE2B f092eeafc23287e5964607c049902aad2f0e7b3f7068c29ba7c24071c0e62b59c5a6d8418e11acdbd155c75de2af6003186014a4df03ec650bb940e542a96352 SHA512 adb80e2f78781bc88dbef27ccf7cf20eeab057ef458f0e9b4c4c89f70c16ffebd413b53679effe580dde29a97d8e3013fd2efa1f5b2d36627324fc6d1e90dc8f
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2023.9.26.ebuild b/dev-python/tifffile/tifffile-2023.9.26.ebuild
deleted file mode 100644
index d585386c5ea5..000000000000
--- a/dev-python/tifffile/tifffile-2023.9.26.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read and write TIFF files"
-HOMEPAGE="
- https://pypi.org/project/tifffile/
- https://github.com/cgohlke/tifffile/
- https://www.cgohlke.com/
-"
-SRC_URI="
- https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/dask[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/xarray[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/test_tifffile.py::test_class_omexml
- tests/test_tifffile.py::test_class_omexml_fail
- tests/test_tifffile.py::test_class_omexml_modulo
- tests/test_tifffile.py::test_class_omexml_attributes
- tests/test_tifffile.py::test_class_omexml_multiimage
- tests/test_tifffile.py::test_write_ome
- tests/test_tifffile.py::test_write_ome_manual
- # requires tons of free space
- tests/test_tifffile.py::test_write_3gb
- tests/test_tifffile.py::test_write_5GB_bigtiff
- tests/test_tifffile.py::test_write_5GB_fails
- tests/test_tifffile.py::test_write_6gb
- tests/test_tifffile.py::test_write_bigtiff
- 'tests/test_tifffile.py::test_write_imagej_raw'
- # TODO
- tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
- tests/test_tifffile.py::test_issue_description_overwrite
- # missing data again?
- tests/test_tifffile.py::test_issue_trucated_tileoffsets
-)