summaryrefslogtreecommitdiff
path: root/dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild')
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild
deleted file mode 100644
index 67419d0063ef..000000000000
--- a/dev-python/tikzplotlib/tikzplotlib-0.10.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="
- https://github.com/texworld/tikzplotlib/
- https://pypi.org/project/tikzplotlib/
-"
-SRC_URI="https://github.com/texworld/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- app-text/texlive[extra]
- dev-python/matplotlib[latex,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/webcolors[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest-codeblocks[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/mock
-
-src_test() {
- local -x MPLBACKEND=Agg
- virtx distutils-r1_src_test
-}