summaryrefslogtreecommitdiff
path: root/dev-python/timelib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/timelib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/timelib')
-rw-r--r--dev-python/timelib/Manifest3
-rw-r--r--dev-python/timelib/metadata.xml11
-rw-r--r--dev-python/timelib/timelib-0.2.4-r1.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/timelib/Manifest b/dev-python/timelib/Manifest
new file mode 100644
index 000000000000..0da5dbd29bc1
--- /dev/null
+++ b/dev-python/timelib/Manifest
@@ -0,0 +1,3 @@
+DIST timelib-0.2.4.tar.gz 295951 BLAKE2B aa543f8ab9ad18107e6caf4e2eff7471147b0ea100533f456cbaa77a0ab318a97b02d0b38777ebe01384e43a70edc0f55acdec08e95a4b6d8ec438140e94ddaa SHA512 b19ef411f7a6d4f9e43e4de2a4c57f1f430b5c16ec88f7c3f72e8a2f6950a2e94c1ce3792203ba3add07994d1a8eaec4172aa09315b39df4494430e30ebd880b
+EBUILD timelib-0.2.4-r1.ebuild 698 BLAKE2B 7d9e42e6e3a9dfbf6617c69dcf326c73b8cd347beea82503765a6cc6aae30b755dc94e2d152b24a696bb849287c137867e5740cba465f4e3e19dc1a4fa958ed7 SHA512 d340ac38df9f5349486e9dd4b0eebd5f556057daf02dfa40339db80123000348c81c18f23ab9e7ebecea7b63223ef6610bdb34f5914db88b5e54f42e9440bae1
+MISC metadata.xml 310 BLAKE2B 008750cf1e8caee9e525cbfa194a3c6090cf6c31fd6cfdb471c4e2210344d198f8a475c656d80b872de008e544203fc3b8f09e9b399634b8fbaad74d9ec9200f SHA512 10849bb8c428f8a211ce1902dbeb3da74922aac33ec7b95df5b2b3dab4cb60e64e399eabeaba48f62455dcea808dfea43daea4593e0529c6d3d58402be06cb46
diff --git a/dev-python/timelib/metadata.xml b/dev-python/timelib/metadata.xml
new file mode 100644
index 000000000000..0a112a630eb1
--- /dev/null
+++ b/dev-python/timelib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">timelib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/timelib/timelib-0.2.4-r1.ebuild b/dev-python/timelib/timelib-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..a269e77685a4
--- /dev/null
+++ b/dev-python/timelib/timelib-0.2.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="parse english textual date descriptions"
+HOMEPAGE="https://github.com/pediapress/timelib https://pypi.org/project/timelib/"
+# pypi zipball lacks tests; also it's .zip
+SRC_URI="https://github.com/pediapress/timelib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PHP-3.01 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}