summaryrefslogtreecommitdiff
path: root/dev-python/tinycss2/tinycss2-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/tinycss2/tinycss2-1.0.2.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/tinycss2/tinycss2-1.0.2.ebuild')
-rw-r--r--dev-python/tinycss2/tinycss2-1.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tinycss2/tinycss2-1.0.2.ebuild b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
new file mode 100644
index 000000000000..40307a78ea0c
--- /dev/null
+++ b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="https://github.com/Kozea/tinycss2/ https://pypi.python.org/pypi/tinycss2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/webencodings-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/pytest-isort[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}