summaryrefslogtreecommitdiff
path: root/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild')
-rw-r--r--dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild b/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
new file mode 100644
index 000000000000..6cee68230e71
--- /dev/null
+++ b/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the stdlib 'tokenize' which roundtrips"
+HOMEPAGE="
+ https://github.com/asottile/tokenize-rt/
+ https://pypi.org/project/tokenize-rt/
+"
+SRC_URI="
+ https://github.com/asottile/tokenize-rt/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+distutils_enable_tests pytest