summaryrefslogtreecommitdiff
path: root/dev-python/tomli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-04 04:27:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-04 04:27:18 +0100
commitfa275aeb316ed5e68498ca0057b27a1e9c887e26 (patch)
tree1a167f06787ef709edff61d90f369164a0683705 /dev-python/tomli
parent9b22dab88308071d43d47cd078b37903900f47d3 (diff)
gentoo auto-resync : 04:10:2024 - 04:27:17HEADmaster
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/Manifest3
-rw-r--r--dev-python/tomli/tomli-2.0.2.ebuild40
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index c8753fb86f9a..379561afa4a0 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -1,4 +1,7 @@
DIST tomli-2.0.1-py3-none-any.whl.zip 12757 BLAKE2B 0a33773bc0409831aec6ee803ef0ef9d6b6b441213d549184068e218b73d6178d617bc2b58d11db98f0e6284baaf81663723fbc6eb89f7466608f0d89aeb1982 SHA512 b6164b03d3db360093f92e644e87a37a0ce20d63d7e9e271fcafd727f4fdb73ad6b301aaf32b3d2839f6eedbc8ea499dafba7335b8fdfc4667e30ed50c9805b4
DIST tomli-2.0.1.gh.tar.gz 133685 BLAKE2B 0d3a1f4ee4e74eeab6a7e7c3d5e866ce1baf9017136cdc8ce1f6275f8d6d151239e5a00b97b6409872fac0e8558a49120adf16f0ae21f9d92ae630dfd39cd6ff SHA512 a467f8d48cdbd7213bd9b6f85fd48ba142ab7c9656c40bb30785e1c4b37a9e29eaed420f183458ad20112baee8413ebbec87755332795c8f02235d1018c3aa5c
+DIST tomli-2.0.2-py3-none-any.whl.zip 13237 BLAKE2B 642af1b59a2b2bceeee2480208f3680ec699bc9b572bde186ff8c845526e41e2ebc145f78ae4094ae3ee084ebfde561ec635358ff3df9c5609101c96d0b54ded SHA512 ad8278fc99a6913ebb70a618a7cad7acca9737e6ec546c932b4d0c1caddc1e70ef832340a33f2db974235459ff627949308d517b3c3a15b6baf8a4f1b3095e49
+DIST tomli-2.0.2.gh.tar.gz 135227 BLAKE2B 1d61fd26793c4f814ed606a60b85edb388bf97d6fd17c830504971be725c84e9e6e67904170cff305fdb7be8196b56d0cc29dd36f8b202798788f4839ba8ddc6 SHA512 3eeea334d6d225590a9e074685c65d052e2f5d5286ca895ff7e9532d7289f0daa31ae67b5076d803e5adad4f20a9831058a0c4599715f049079904934d3d9c25
EBUILD tomli-2.0.1-r1.ebuild 884 BLAKE2B fa462e0cad48b67e78f91f2d29969903b26e2822300c936b3d2be1e4a10d6d877a1843b51a63d44a804b3ad3710bab5ce1f8b4f4a4f3dac3cb7febb2e6b3bcea SHA512 cc77efe5c1fc79d2e811cd51ed0f699b1f75ddeaa0b15691e5fddd1ad1dfbe9ee0387e17d6e0f0a6a730f4f05a659d90e6f65c3724cf7835679b16a6958f87eb
+EBUILD tomli-2.0.2.ebuild 892 BLAKE2B bd336d4220834682761a9d0908f5824b5f95c0f9536b0c9a0b2aec9ee1ef2802e4593d9343f0aa109ce19b22a7d47880e6123ad4dfddfb69826e3daf8a2f3910 SHA512 860c6bcecd578f905b213523dd31f0b96256e01ffc778ccf5a55af982da407891e6f49ca3e10a71c917925b4e7429dab57a01719a4c0689a1499d01e82cb6a3d
MISC metadata.xml 363 BLAKE2B 2c80a2c2a8959a93e392da0e03303ffdae0a3291624c284f91d747d13983cbc188d8a64f8763ea484f792d5a42e355381034f69fa0acde382779e4ae53ac2154 SHA512 42e8d4b4d1ec773b53e8e119ce6afb74acd64de998c372c6f6ab64f70713dd825420d1e1af83b5f647dc03a917b1904d65f0cd06cbddea47a33a558be2c89562
diff --git a/dev-python/tomli/tomli-2.0.2.ebuild b/dev-python/tomli/tomli-2.0.2.ebuild
new file mode 100644
index 000000000000..2ff54bd4c53d
--- /dev/null
+++ b/dev-python/tomli/tomli-2.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/
+"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ $(pypi_wheel_url --unpack)
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ python_domodule src/tomli "${WORKDIR}"/*.dist-info
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}