summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
commit3aae425b3c39d02e2dc917db0fae8c225c158ca1 (patch)
tree89f296451fba2217a7c18592ecb1762a920dead7 /dev-python/tomli-w
parent6ee17dd82a3bcd0e90af4ebfbb3e411d342761be (diff)
gentoo auto-resync : 10:10:2024 - 04:03:57
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest2
-rw-r--r--dev-python/tomli-w/tomli-w-1.1.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
index 8a5c1965e446..46a863b369c6 100644
--- a/dev-python/tomli-w/Manifest
+++ b/dev-python/tomli-w/Manifest
@@ -1,3 +1,5 @@
DIST tomli-w-1.0.0.gh.tar.gz 63862 BLAKE2B f10dc80ce76edafd78fc66dd488a35bb0e1d8bf31d0cc0e3b970be19f5cda40d992fafd46d1361b55df4a787d48f38260ac2be77def7ac938f62144e4c810897 SHA512 406f81e4e8151e55e8367031b5880f51de41016711238a114c82962012de4b90d5e465c503a8979d565d07843fbc4804a53c29848e4f6e5f20f9ec5dc5ce536a
+DIST tomli-w-1.1.0.gh.tar.gz 64682 BLAKE2B ca4cee4931f2df5ddf58cfdc2d28a20fcac7c7efe576dcbe43f2d30e0f5b9747f10632dd2b466fc769e2823896450876592cf518665f071cf6af55d9d3f94bb5 SHA512 0755004461017d3a62059ab74651c1fa0d2c67e224935760daa8d569b996db99e6c4077c92127b303a9026cf689d3db6a75cdb8d9178d9d3009b747b43ca2057
EBUILD tomli-w-1.0.0-r1.ebuild 647 BLAKE2B d4f8d9f130eb84dbf002e74b346dd3dcb4cfc9be39e37238bdb2c7c03270e2b1152837db06d875ca21504038b9a753ec5dc1f0822311420754eda20c0834d5b1 SHA512 3b670e911174767d4912f9d2f8e3db52def3722d0c73fe47cc6f5699cd3e0408b1fc8895e7e731a279f5dc7e6282801bbe063981f288149e1b8d60e3b37f9b99
+EBUILD tomli-w-1.1.0.ebuild 658 BLAKE2B 896cc62727e2ee7181b7acd3cea45cc9b7ab8c9613050bcf39efd6ec8b9d42009e4ae1f955491d2cc7223089b1139bdd00a3430499c39fc9da5757696ead188c SHA512 1b2b0ebebef6b0516665bb409b1ec266e4a13d7ad0e110b30e24e010e1f67f888acf5511cfd116ca02fdc29627f6af38dd10f3bdd082dd2bf5025e262f04f003
MISC metadata.xml 367 BLAKE2B e088ed9141a1b4ad1506ce67b48a6666c9bf9c84e761906a95112a81d4cd9b98ebd0db756cedf007c3f50e39321697f8fc91ef6e49e668ca794ff78e8b03080a SHA512 784aff95fbc1cb65e4eed20258499260400fe31feb96acc6fbde00353d629595d8e23ecc6b550bf608294fc882c42063d0a23699defddb6699df59add7e8acaf
diff --git a/dev-python/tomli-w/tomli-w-1.1.0.ebuild b/dev-python/tomli-w/tomli-w-1.1.0.ebuild
new file mode 100644
index 000000000000..58d5037ee9f2
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/
+"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}