summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-16 06:41:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-16 06:41:40 +0000
commitcb2f73d10494730ba590096a1f24ebc6d0d61a9f (patch)
tree6b17212245a07479b72573fb8380352300de6b65 /dev-python/tomli-w
parent8e26aeaca2a19592a9eea3917f3139bfde8641f0 (diff)
gentoo auto-resync : 16:01:2025 - 06:41:40
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest2
-rw-r--r--dev-python/tomli-w/tomli-w-1.2.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
index 9a1f4a4d87b2..988c0fb5b688 100644
--- a/dev-python/tomli-w/Manifest
+++ b/dev-python/tomli-w/Manifest
@@ -1,3 +1,5 @@
DIST tomli-w-1.1.0.gh.tar.gz 64682 BLAKE2B ca4cee4931f2df5ddf58cfdc2d28a20fcac7c7efe576dcbe43f2d30e0f5b9747f10632dd2b466fc769e2823896450876592cf518665f071cf6af55d9d3f94bb5 SHA512 0755004461017d3a62059ab74651c1fa0d2c67e224935760daa8d569b996db99e6c4077c92127b303a9026cf689d3db6a75cdb8d9178d9d3009b747b43ca2057
+DIST tomli-w-1.2.0.gh.tar.gz 65320 BLAKE2B d48174d177a5ed13880ba8c9c6beefae8ed43b0a3539441ecc17aa32af07428d9f7d2c2d185264a20f27ab2ab9b5085b91da120e49dfc17a0cf36b590ebfa81b SHA512 d7b5888d7e60eda701c4d3d02189b9e26467a647ed4e09f55ee325c6d62618de6a6b299de522d105decaee68fb9804968c59d4c911bdfb7520a0beb6c05f432b
EBUILD tomli-w-1.1.0.ebuild 650 BLAKE2B 58c713943b2ecfc5f8a4fd10cdb6a341ca96a8088dfb674a1e6bb957b30d8fe07ab2b62336f0e38c61305e2c19ba7bd231f9d7846293ef09ee673f7b9e7a5472 SHA512 f5d3c5b11fbcfbab4eec9bbbc8ae4c4271e14d6f986026b51e8d3ae50ef9e9d53435db5c0f61a342e9e55f294972573e9a9eb1bf143f197610be81567eec7a6b
+EBUILD tomli-w-1.2.0.ebuild 658 BLAKE2B 7b4c74fbf94d6c73f525fc9e935c17aa5af419d85028be6eaa7d11bfc159e60525408318ac8d96aeaf7f4c566e21094cbfd19b6adc2f8fb8ad36936a4db31b90 SHA512 3bccaa1413f38e28fa705e908ac76ecade3007f4e9a86045902eb2ea154d7ac83d9b13eb7b821dafaa32cae2309ac33a597a6414161e82caf2ab27cffc37479d
MISC metadata.xml 367 BLAKE2B e088ed9141a1b4ad1506ce67b48a6666c9bf9c84e761906a95112a81d4cd9b98ebd0db756cedf007c3f50e39321697f8fc91ef6e49e668ca794ff78e8b03080a SHA512 784aff95fbc1cb65e4eed20258499260400fe31feb96acc6fbde00353d629595d8e23ecc6b550bf608294fc882c42063d0a23699defddb6699df59add7e8acaf
diff --git a/dev-python/tomli-w/tomli-w-1.2.0.ebuild b/dev-python/tomli-w/tomli-w-1.2.0.ebuild
new file mode 100644
index 000000000000..2f7ec5bd9ea1
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/
+"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}