summaryrefslogtreecommitdiff
path: root/dev-python/tomli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/tomli
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/Manifest2
-rw-r--r--dev-python/tomli/tomli-1.2.2-r1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index 32fb84a4cde2..9f69296a4992 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -1,5 +1,7 @@
DIST tomli-1.2.1.gh.tar.gz 122701 BLAKE2B d0280bb81a6e931a175c6ef2c58b4f36b1237f99a73331cbb95f98b9e68a98a4c6a635aa12751ac46492c2b1a06a821f1ae70cd0c36f268998488e824f3e577c SHA512 34f9529b137331b0ae03ac99170b3f6509847356594be14166bae306ea4fbbddff808ffe0c48d05434f72d223a2f35b511675217053029d287725b7142fbd089
+DIST tomli-1.2.2-py3-none-any.whl.zip 12118 BLAKE2B ae1dbc14e3c7c79240a327f3fb622c16aeba561274aedc93957549d838fcb2b6ed5889f8c28344a4cc9dbb52eacd6b9dc53aeff8f08642a8abeed2dd67c989a1 SHA512 fb9452663a46760ea442f2f06ad2f60b094368680dae315c2386457041f3ac5399c196ceec0524d432442ec72158c2d95bfa5d0cc288163b4eb1d6a07a62ae36
DIST tomli-1.2.2.gh.tar.gz 123150 BLAKE2B b07527a2a83615030037867c6011440a3814cbe265e8a760cca08e324954dbf7d1a393bc900559ddfc1bcbe1911f758948051823d9ef830ee05abb2539374dff SHA512 460ad8ae9a342d82ef12911c0d0e246c1434a5d40d898e91f6c05bf37b7bf9921da05e004c36907d623a797a7a215c1c3faf3f9a2b940f3867b142847a188605
EBUILD tomli-1.2.1.ebuild 896 BLAKE2B 7ee772f1b4f8e1f331b5851f347c911c0d305a3147a7220d7dc15a8d49e9d6fd8ce024f601af1b1d13bdd9b51442f03a930e8751083953d6a13226a9d3fa9adc SHA512 339bc21a22fdd8628d16084421748425a7e3e526fd1161008a21ae5c480f5282c6f9bf06201db6dbba5996d383995a16910fff11b1793ab8a96f724ed0c97e11
+EBUILD tomli-1.2.2-r1.ebuild 962 BLAKE2B 39ab5fc048f80dfd50e784a260f120bb26413a6a97440080569fab3cc74181459d8f914011f7662af55e9f05559bb481c8dfc399c7260710262144968d92b3d1 SHA512 798478f681ba9107a09d324a996e85ebf1e205a8fbbd86b99137a63be558dd10f7b8bc2f7090bdfb03714ceeac2cdac2f50fac0cc8d1ee0d3816dfbaeef926e3
EBUILD tomli-1.2.2.ebuild 904 BLAKE2B 6420df7ae50f1a42d7332c0037db6254af264b8e3e691ff7929b7c7aee0f4e48a39f7f72d822685c3fea4f21705586da8ee3fd6742a9b7c6aaf86ba664918c21 SHA512 b6a596eded3f4990389226beac44216025b2a9f4bec2e2dd149a232132ecd3dda808e3278d78ef7678aabef7bd024467bdabbe67e6d386fd894f7df364f8cf14
MISC metadata.xml 363 BLAKE2B 2c80a2c2a8959a93e392da0e03303ffdae0a3291624c284f91d747d13983cbc188d8a64f8763ea484f792d5a42e355381034f69fa0acde382779e4ae53ac2154 SHA512 42e8d4b4d1ec773b53e8e119ce6afb74acd64de998c372c6f6ab64f70713dd825420d1e1af83b5f647dc03a917b1904d65f0cd06cbddea47a33a558be2c89562
diff --git a/dev-python/tomli/tomli-1.2.2-r1.ebuild b/dev-python/tomli/tomli-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..d05ada7dc1af
--- /dev/null
+++ b/dev-python/tomli/tomli-1.2.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+ -> ${P}-py3-none-any.whl.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ app-arch/unzip
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule tomli "${WORKDIR}"/*.dist-info
+}