summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /dev-python/tomlkit
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest2
-rw-r--r--dev-python/tomlkit/tomlkit-0.12.5.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 9957e08d0ba6..edeafff7834f 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,3 +1,5 @@
DIST tomlkit-0.12.4.tar.gz 191162 BLAKE2B 3a5f8f01c7965a6d445fa96d0253d0dad55414bf9cae875fe9d9bc670d5b0a20a76fbf655695396ea188cddcea7ad034a38eed05d85f48c47301a3f23a9c7ded SHA512 b6b1cbb954202a256411388eea46852964bbdd02026086a42eab9107c55b961718398ec504f0289560894e9b46cf1c2f4b7e943267454509f6212e899e161d05
+DIST tomlkit-0.12.5.tar.gz 191420 BLAKE2B 3175f2932db1da3aca439581c7a11fd2dce01dff3c9d21b07577bdf38138515105939bc864510dce1f98e28caa222b6ba94a0d0906b515e7b677c405b90bf77c SHA512 85fba0018059c72f483251e53c039ede4ed630dd31afc58a1555705281a42c090aee2d8c25234b8700ff5f3a766313d7c9c716d7224f608f22f836c9e701c251
EBUILD tomlkit-0.12.4.ebuild 971 BLAKE2B cde0302c2500820b0f1e9308686706f867b45e22f59c6106b453a363d571e91687b65cdf9f29c1da3b2b296fc294726d12f067c418fc0e80c3d3062f8c0cff5e SHA512 11ec5bc0edb4d67a6d859d6a3561f63093226f159cd4c4284520da927d204c2128f8dec528fb4f1a796dd7ce0557d49c6bde95c7d4356275a63db754105f148d
+EBUILD tomlkit-0.12.5.ebuild 979 BLAKE2B 8172ccd3cc70d7e7a7c91e90bcc4458e824f0bdf7c0aaf51cd13a01055696620a40bdac681abfe145b7e79470004b5be7df30ad12b0ee271fd55c07ccc1c641f SHA512 7ded503e0f8947f1f18f9f4ada5f3f4965c1dcc4440cea7fdfdc19eb9b2110311c28693a5b485cd61bfdc9ddbc1104e1e4779819893e0bab9e1ef2923282fed5
MISC metadata.xml 525 BLAKE2B 663169c851817eb7368c49d678119f1f2dfebe642325d3dbc59498f60b452710a257ca5cd5173a4fc8391d33038cce079b3fba112ad7e9c0caf0c1872ee43f13 SHA512 5a6cf412fc06854557d001ae4a6f654b36d351c8c0b4bc08c1a7c40f49d8dceba931598f5eed6c75e1d7797570fcf8fb7799f5f035931f80d05b1e9bd0d258c0
diff --git a/dev-python/tomlkit/tomlkit-0.12.5.ebuild b/dev-python/tomlkit/tomlkit-0.12.5.ebuild
new file mode 100644
index 000000000000..909ac0927d76
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.12.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}