summaryrefslogtreecommitdiff
path: root/dev-python/toposort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/toposort
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/toposort')
-rw-r--r--dev-python/toposort/Manifest2
-rw-r--r--dev-python/toposort/toposort-1.7.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
index 1fb4c316588f..50966618de55 100644
--- a/dev-python/toposort/Manifest
+++ b/dev-python/toposort/Manifest
@@ -1,3 +1,5 @@
DIST toposort-1.6.tar.gz 11690 BLAKE2B a9a57fd182a3324d43112c3f84a20039f032d99bf2c35c6678a6a08c23b123f18610f460529dd39c769b935d98270a25ded2f1a483e4e6f06d3ccc501b340cb8 SHA512 8dc30b5d5a6f476756520236bc93840243690779783ec8f0b5ef0f72c64d774177b25d10d2e024cda968f81352abbc4f89f3069760fc3a86bd5ee387e7951928
+DIST toposort-1.7.tar.gz 10671 BLAKE2B 89da22e803c334cec77d5ac8ad6a9ab8013f7516555c2822bd6d511edf28230c85c2eaeabad3dc4a24a58ae3ce3850d407ad957d0e28491574557140a286843a SHA512 a585d1c103b2162fa3f37f6b0ef60a8709f08d9543d7fab619af3718bf9f752a293e50061d370fd08872b2d8a8db504cb9d9c1cce5446885b46fe8e833813833
EBUILD toposort-1.6.ebuild 413 BLAKE2B f9f0958847ba209b9d07593b17b8f0d802fb2c1d95da6bf3465b782015c8bcab0ec6bcb11f1397c844e941c3f8dc8d51b6929d1bf31de95655cbf7b66ed7ffbc SHA512 56af58526ebaed5cd44ee0e1cc50dd1e09df469699a2c0277d0bc328dc9a5caaf9fa71ba6dea7856f36e9cca09fb0f6027154d63134a0e170ed7ed9978c250b1
+EBUILD toposort-1.7.ebuild 521 BLAKE2B 4d6875baf0dc19305bab782173d709fb144efc181bacc452bb6ae45ae78513ba088e75e05a2854bce4089b0a16851b6c342a5edbbd96e30a7857294d708d18af SHA512 b0e5dd3058eaf010a22d2337ad1c9a9fc3169e1410e5e207e0511864524e3b07ea08387d8ed666f338be4eb6650b59275785f52b78ffe2bc594941fc7c8fbc71
MISC metadata.xml 551 BLAKE2B a8d8483b1a725bfdbb0c5ed3688bcd15093f0a51fc56cf8cdf30a836c98818a5ca5e7732e8045bd9cba76dde69aa05f2be45f9765f48b2177e9e8aa67a726880 SHA512 f2b0b6fb5f95c0f946149c1d959affa926452acfc21e46dda6f34448c8799df4fb8ddefc3856cb09420bed26f41c945ff309514bdc3fe87c77465784f3c57cf5
diff --git a/dev-python/toposort/toposort-1.7.ebuild b/dev-python/toposort/toposort-1.7.ebuild
new file mode 100644
index 000000000000..3002de7baf9a
--- /dev/null
+++ b/dev-python/toposort/toposort-1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://gitlab.com/ericvsmith/toposort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py || die
+}