summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
commit22f5aa1d3324a28622ae4bc828ee77ee079edbb8 (patch)
tree9dda4f0e2d4085105a470d17b1d6dc04cf4ed6fe /dev-python/tox
parent8e2875c48ca3030fa53717c6fb773b63eba7ca6d (diff)
gentoo auto-resync : 13:03:2023 - 06:14:36
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-4.4.7.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index c562ca606742..9f3761b0c2d8 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,5 +1,7 @@
DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3e67825672d0efc74c1b1468bc8b8d9c14b6177c181750ba4b9a5e77d616068dd83e21f5641acfc8e2a271cc1f SHA512 64816754e6800661bb564c5c7d21c4139522d540a04fafe3c4591d596072d48d1cbe0ee2abee9c8faf3d5007774f5371431b5a7a8f49912bc879c7b168aab2ca
DIST tox-4.4.6.gh.tar.gz 304337 BLAKE2B 2c157fe5febf1eb131d767ade87484880201bb37fa65a579abb9780d755d570f216b8f865dd2dd8dbb3a3af01be78133f9ac0b73a3166dfc2b9cd99f6547498a SHA512 403bca89228d665182bfbb61550dfd9e9fb4ce4a5592472d50cd38e3f264c806fa15bbdccc020a720ad69885d9be54a1f074f6d87549cbe2b523e53d870358dc
+DIST tox-4.4.7.tar.gz 168261 BLAKE2B 276842bb82d01c9e3b66f633e79974790b7d1852f831ab954172ddc1d3c50c861a39e959fb0a990a7102a1cc0840238ef3ac84c7b41f9f45ce502b1245e21988 SHA512 58989ecc0a555ee225614d9b7a718b22f6dd1555a0209a0c1428259fbfc7d336a58753fbfa85f1b9aa160c8489587999425437e71f9d4728631d5cd5b50ca159
EBUILD tox-3.28.0.ebuild 1916 BLAKE2B ff8aa55245a3f654897ad4c8f5861a55410b2b9442bf3f85aaa0ee236f576efcea1a2ed697c715c7182679b62a4781c5a0f6236eb92a1b12d6ddc73154612a67 SHA512 2f5999d0263da9efb00216600f8b98fb3c204e11640049d92c6106279baeff452468d2bb78236839bc8bd5540d6f9d01338af26315148d81a788d476ec5dbed5
EBUILD tox-4.4.6.ebuild 3029 BLAKE2B 3a3dd193f9eaed38066e520aecda87b81745ec4a175b9a6f6e65a701c85db0c46d2b9c8c3d5b9cac29ef1cf91d21f313d79e673b1e31587e502d7886960e398d SHA512 2ff026c0923e832e3af257fcffbdb5b7722a50d010205723983a6f866b36f63e5665b4466f7cceeb6b04db8bbc99b3e585bd94094b6a7afca2a079a9ce0c3c47
+EBUILD tox-4.4.7.ebuild 3009 BLAKE2B c9f8e6c1cd6260a8a6cefc8045bfb24910e893fd1dad27f30ce52242f24f6528b428f812d47ce75359d32265e29ad7372ec7462fbf506089769899df2bd7a96f SHA512 d8df48dd80e192e69a9f8d9d7b9ff8f19e3efde8acf531eb697e48e81603e765919199d0ac6c812ccbaf72e02649c88830cc2cc6e0c98119d1bb1d52647bce34
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-4.4.7.ebuild b/dev-python/tox/tox-4.4.7.ebuild
new file mode 100644
index 000000000000..2248781df596
--- /dev/null
+++ b/dev-python/tox/tox-4.4.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.10[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # the minimal bounds in tox are entirely meaningless and new packaging
+ # breaks setuptools
+ sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
+ # workaround https://github.com/agronholm/exceptiongroup/pull/59
+ [[ -f tox.ini ]] && die "Remove the hack, please"
+ > tox.ini || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ epytest
+}