summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
commitcc901a8ce7c6bfe97e3b4f048619693d360ae348 (patch)
treec250ff07a4d508fa08b487b616e0ae8aff2f0d8e /dev-python/tox
parentc9badf79e4669147edb94182af5776072f2ffaea (diff)
gentoo auto-resync : 10:02:2024 - 11:34:00
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.12.1-r1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 2048719ae082..d23c7243b0c4 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,5 +1,6 @@
DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3e67825672d0efc74c1b1468bc8b8d9c14b6177c181750ba4b9a5e77d616068dd83e21f5641acfc8e2a271cc1f SHA512 64816754e6800661bb564c5c7d21c4139522d540a04fafe3c4591d596072d48d1cbe0ee2abee9c8faf3d5007774f5371431b5a7a8f49912bc879c7b168aab2ca
DIST tox-4.12.1.tar.gz 176858 BLAKE2B 805764e507ba2894e46dad6b82eb928b4f184d20b2ceb0e7c2ff15f553121158f7f84515a5922d095893a1d6a73030777300163dfdd60964ffe6c41cf2047c14 SHA512 217fbc2933999fcc5d080d97521cd01b7d9a35d4f1542cc58bcc2ff86d07884caa43fd42b09e5064cbad1334e4df9cd717c48c70041c9cf856b0beb22e1ea8a7
EBUILD tox-3.28.0.ebuild 1916 BLAKE2B ff8aa55245a3f654897ad4c8f5861a55410b2b9442bf3f85aaa0ee236f576efcea1a2ed697c715c7182679b62a4781c5a0f6236eb92a1b12d6ddc73154612a67 SHA512 2f5999d0263da9efb00216600f8b98fb3c204e11640049d92c6106279baeff452468d2bb78236839bc8bd5540d6f9d01338af26315148d81a788d476ec5dbed5
+EBUILD tox-4.12.1-r1.ebuild 2932 BLAKE2B db764c9e83ead2c4ec2e93fbc8a9330cbcdff3e57b5adbfde6751dd3aadb8bede6920fe8532d2d21bdaa4289c0f4c7930a951db40e00eb4987a4fb68b7174d83 SHA512 afed59ed1aa75de4a1c1e1c1758736c6ba66c6c58f32f8f7eb757d797807b5f722c403d98737e3fa20a4b95c397c54ed3bca11ae9adb27527b5e1ad6483db0ed
EBUILD tox-4.12.1.ebuild 2925 BLAKE2B 634892f6154b47e36096b94ea7d91822caa46d7c1bffe282d99c13a06147bf0940853144b991f937058405bebf0c0ed2c3ab20b05096f75c6f3bf549471cee8e SHA512 b3a65a34cbf769d5d2233db0d757385111cc7192b3e42301f7529cfcb904d5f6df9ae0d65aa12469bd8e2ac7324b1e7e363ab8869744762db08f8c94e6e2ebd8
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-4.12.1-r1.ebuild b/dev-python/tox/tox-4.12.1-r1.ebuild
new file mode 100644
index 000000000000..21d8b3db653d
--- /dev/null
+++ b/dev-python/tox/tox-4.12.1-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/pyproject-api[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/distlib[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream lower bounds are meaningless
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_run_installpkg_targz
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_IGNORE+=(
+ # requires dev-python/re-assert
+ tests/session/cmd/test_sequential.py
+ )
+
+ epytest
+}