summaryrefslogtreecommitdiff
path: root/dev-python/transitions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-25 14:56:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-25 14:56:25 +0100
commit5c42677148c717eb9f4673237db807f74740b4e9 (patch)
treeee9f721e91477693459f31721790f2f41839a74c /dev-python/transitions
parentc9b5a916efac64df2a39870a92cc6b67116d1b9f (diff)
gentoo auto-resync : 25:08:2024 - 14:56:25
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/Manifest2
-rw-r--r--dev-python/transitions/transitions-0.9.1.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index 8154ca3b34a7..a034877d71a6 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1,5 +1,3 @@
-DIST transitions-0.9.1.gh.tar.gz 1124905 BLAKE2B 6d8700c9b2b2d200c8377e698f4057caa78908ee7156daa3fce1f49d86c6bc9afd45fe7af4122c2e124681c3c581e98f657e39444595f97ed7fb3c64f57d70fd SHA512 8e946ee9b8e3ed0629381514b4af4446625de0cea7cc8780326829ad987b4c0f9402484ed98ca66b12e95c8da79f77c62aba9f000dbe42779f158529cde3f279
DIST transitions-0.9.2.gh.tar.gz 1133297 BLAKE2B 9acb83355236941d49bbdc1877e352e1f86d2b95302455fc5ea2e13d9014f8e6c9dc67e04b70c03c40e3d10b9bcae97900420bfb7549decd7c2186284d9f7389 SHA512 7fa392b185b001b0224b449d65b345f71afa27f80a88d862456f637e5876644f09ca861ce8bd2ff93f91a7846e337a996f256645140a0892b526cd6c1f58ce7f
-EBUILD transitions-0.9.1.ebuild 1190 BLAKE2B 918e57b4a1e6e7025e79676faba34d5af1665ebe7fd51464691b39021609e3407db6e3577fa7eb8a169d9d6321c3b941d96c3e09abd66a78c00dec22993036aa SHA512 470396fe635c9e31d9353aa400075159f84cfcec21ac8b37fe5e3888c986a62448adb40bf326b37aadcb06bb06da84f4e8b49244b04aa2c8448c38518c5c4480
EBUILD transitions-0.9.2.ebuild 1009 BLAKE2B 6d3c5e687620410c0f0a4d991494d8800fcc8fb63cb38b242352af94fa5de73812cdd2fe1b3ddf4ac0e8878ff94953b3c54a59c1578df01ce5854bde225c7113 SHA512 bd0247b587549b2eb01d60be619ee3a16005db2789ca1c23c27bb74eea8a4889abb5c8fdb4f3aeecf22f666eba223c6dea04354de1ba8ebff10fb8d1f68703d6
MISC metadata.xml 863 BLAKE2B 8ab7f50602ca6a7723c10c29c0bf436beb742e389fea5d4b98acf1828fb3287af27fed05f6c9e61cb65059d51a2290e0fe69515c1a67b138cfdac4cbaa7752bb SHA512 6e440169ae4a16c53f2a451d9f32e3d4831151b3af8a5f95f157e32a01cb2fde56bbab13e438c88f10e79fe37fa5ca6b48e18bfa9aaa81b96b7c703e2125356f
diff --git a/dev-python/transitions/transitions-0.9.1.ebuild b/dev-python/transitions/transitions-0.9.1.ebuild
deleted file mode 100644
index a353fdacea25..000000000000
--- a/dev-python/transitions/transitions-0.9.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
-HOMEPAGE="https://github.com/pytransitions/transitions"
-SRC_URI="
- https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- || (
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/graphviz[${PYTHON_USEDEP}]
- )
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # magic to ignore async tests sometimes, breaks EPYTEST_IGNORE
- [[ ${PV} != 0.9.1 ]] && die "Remove this hack"
- rm conftest.py || die
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # pycodestyle, mypy, etc.
- tests/test_codestyle.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-src_install() {
- distutils-r1_src_install
- use examples && dodoc examples/*.ipynb
-}