summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/translate-toolkit
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.5.1.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 4aa64fb0639b..cab891dcbb77 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,4 +1,6 @@
AUX translate-toolkit-3.3.0-no-install-docs.patch 652 BLAKE2B 202cfd408059115cfdb5933320b5a560eeee37e2c045cedcdd80cf808ab1e1a5569a964e9eab8114a2ab27e2c470285b254406c754b5289f7cff2f22afcebb6c SHA512 d98e2d7519ca630d41407d01f20543a84c3f408628832d4e79a5a52437d204f872aaef8eca80687565e6981dddb59480a313217eddf8a4084d8b6d71c3d2c0da
DIST translate-3.4.1.gh.tar.gz 1147673 BLAKE2B 3a29b06f944752e9edb30c9b3efd681d7cd7f75fc9a320a3a8d9e74d497e43f1a1a4e18649174e4b28f1a3b2223d735ba411d32736b1fea36237ba95f8021217 SHA512 e2ff9b2c5de58c15ef7b11f1339be7b36ffda3368b91aa647585c9dc0f4c9f1c1ffac9165e0e963cb3c10fdf6ce037ed99d82b6156e7c104b4216c8d46dd709e
+DIST translate-3.5.1.gh.tar.gz 1147898 BLAKE2B f9fc96065727e0016e61fd581690dafc3021471de9ccc9012b223c24778669b984e0bf0ab5f83a910af0e543b0e4793afa110c5b2ced890a257f72512bcaf58d SHA512 2125e3ab019a6b721327d6979482562d5984df28b04aaa69d11e44b6a7396ee387f79d8242a20a84157f9b62457839b52599eb0fe13abac33c9a312a84d55d30
EBUILD translate-toolkit-3.4.1.ebuild 2508 BLAKE2B 94484792689ffc6a1e1caa613e3cd9b4a54c3ee50e9646bf7751ef241ece1aee0882ed392d242c2f280f5fe951d187fe2875da1fc8185101c9caec6bce6f43c0 SHA512 af4cf76d013e186be0380e601ef2846e9159ce8159f5b22ee04945b546f3699bfcffdeef9cdffdd6c3e87c107a5bab80d44f334e5fe4468235d66c1faa00629a
+EBUILD translate-toolkit-3.5.1.ebuild 2555 BLAKE2B 0a9fcbf62458ffb7808805a422e800041109d10f762b15b71978fa1c310849a4c29070018358ff3626b9d9f75cbc826b5053f3b94ee47c0583122680cca6a6d6 SHA512 81886b4f30862eff9e74af6b4c0d9788bf5aa0d31aad83cdced7cecceadd52fbd79e5aa201382393cd9e7ae39a61cd507978a1e1da51ddb028d4c52faa6eb011
MISC metadata.xml 746 BLAKE2B d11f99224b1dd6ccb5a64b2f3346f3963f7874197fc5cd13a9bc84036d7f6d78e62d4f92d80b41b3a71426978c605d599207ba7d20ee94ca195e6be3b60f41cb SHA512 07dfd2ab55c6eb0ab346e66a3f03dd82e193382c6bdec0d2b8826cde7e4e11bb5d6f3bc1a5885b08d9c2aa51f8afedc6ec6684f224951e6dd80bc500c783cbb3
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.5.1.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.5.1.ebuild
new file mode 100644
index 000000000000..15ba26748e40
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.5.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="
+ https://github.com/translate/translate/archive/refs/tags/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+BDEPEND+="
+ test? ( dev-python/phply[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-bootstrap-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/translate-toolkit-3.3.0-no-install-docs.patch
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}