summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-18 06:30:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-18 06:30:11 +0000
commitf57e008aa126ccdca95f7424e4d24a1a83a49682 (patch)
tree485fb1d76c7c51ddd47615c50059dd46045ffbb5 /dev-python/translate-toolkit
parent066666b8767b78231b90d9b3ffc8169fbfe1ec7c (diff)
gentoo auto-resync : 18:12:2024 - 06:30:11
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.14.3.ebuild122
2 files changed, 124 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 190cb6f334db..3d2c4e7c67cc 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,7 @@
DIST translate-3.14.1.gh.tar.gz 1174769 BLAKE2B 3be39dbf964307ebaaca651f06683ecf67e3aaad9ea3774a68190f117867e8a5dc8ba732242fc5e34d53e629474bc038e2dbb2b8383fb914c0aa8325a6a3ac39 SHA512 4052c2062934720b347723a88f2a9fb187c03c064efa88a95992860b196637ed805e2c00986f0337253f56b3ce9f7e064ef33c12f9ba3da4af01b10257449c30
DIST translate-3.14.2.gh.tar.gz 1175450 BLAKE2B db13e59036bd75a62847c68c4e2633a17152def48ccfd1d36531a0325b4b5d819711dab1cb3cfc23abc2e7201b348836434428ed155e6e593273ff8750038faa SHA512 7ae64bd93459b29e6a341ea8ded2993e02e277dbba48a0638eda28fff4dfcc9b490d0a669e277cb75c395f385e5a54feb0665919c27b1ab7c5cffd0add109d27
+DIST translate-3.14.3.gh.tar.gz 1174793 BLAKE2B 9aad67c2bc390083dcacca53a41b99adeff679db4d576c054d8298da0e5114e5204128c94ee924cf4e5851378b3cec7b99d52b2dd12c5ece86562d45d05c205d SHA512 6f584ea46aceb4080eda2b05e3fbe51d76667d8afcac8da4e0b7644965aa833617db031329e315cbb18c6194e289a9054f127814372e97535bc40d765d65316e
EBUILD translate-toolkit-3.14.1.ebuild 3179 BLAKE2B 025da87b5afea5470f79e3328c77a8b3e4d3afdb5787f6bd675d9168b26e08a1386bdd1f4d55ceef4e13fbae3143fead7f15d480f779274cd076d11f57b3e9ca SHA512 3cf541d46de5241a74b9f6fe9479b1c0effc6a77ecb5ae09a5af457bf19ff6e8e53e96c85431afb502e5977e77ba753ed3d00987083e215c76fd38cc53b798da
EBUILD translate-toolkit-3.14.2.ebuild 3324 BLAKE2B ab9fda0e1e2dd6c38e833d93c6df6a85df6dad6915d8e6eb43b8853ab6456c89a60d6ebd42339b4366bec7e90624e75fb7fe4f6fca119780ca44945c766cf754 SHA512 590aeded4c422e39f16648d2f789df447098d66f804be8173588d5de6a43a2f63762c61122c67a453c80c2872e994b7f2c02bb758be7e12a91a3ec61370dbe62
+EBUILD translate-toolkit-3.14.3.ebuild 3324 BLAKE2B ab9fda0e1e2dd6c38e833d93c6df6a85df6dad6915d8e6eb43b8853ab6456c89a60d6ebd42339b4366bec7e90624e75fb7fe4f6fca119780ca44945c766cf754 SHA512 590aeded4c422e39f16648d2f789df447098d66f804be8173588d5de6a43a2f63762c61122c67a453c80c2872e994b7f2c02bb758be7e12a91a3ec61370dbe62
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.14.3.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.14.3.ebuild
new file mode 100644
index 000000000000..5be60825d8af
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.14.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ >=dev-python/cwcwidth-0.1.9[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ # gettext 0.23
+ # https://github.com/translate/translate/issues/5436
+ tests/translate/storage/test_cpo.py::TestCPOFile::test_wrap_gettext
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}