summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-17 12:23:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-17 12:23:44 +0100
commit4d6e1311ded368813dc93f130293f64148e22c45 (patch)
tree966c774d10cd502da9a136e2d595f430efb0850d /dev-python/trimesh
parent2ca31eebd5b7496656193e0aa6ae39200d69a017 (diff)
gentoo auto-resync : 17:08:2024 - 12:23:44
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.4.6.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index f013800ea050..64b243e524cf 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-4.4.3.gh.tar.gz 13606522 BLAKE2B d59c59e11b67c301c0171dc911cf1e518b57f9b3e9d0d4410130922eb0fc5b190ec5d8088e43d35fb7b09687a2698fe41342ce492fafc7bb050431cf43624c9b SHA512 b93ed203589a5467116c942b6d02db7eb4c130b7f110ea2612a2cf4d86d9f7943b949dd62d2229762a2a14f796041aa6a4294857a8fcc3b96d470a6925b9d568
DIST trimesh-4.4.4.gh.tar.gz 13606701 BLAKE2B 52df2a318adbc1ef263734d1ecc55121c486a8d546a5e3452d38f6e580e89dabe72eb8f437e023391bf5ae10a145d453ef1b3309af8d7a8fd37d20aa14f92832 SHA512 afeeca5532208bacca9e5539d894f72c7e93975c9f932487a852033ed75d20fe29a66880c62d3daf1ff328c198e40464ad3751c69e190994fd0ccc19da5723cf
+DIST trimesh-4.4.6.gh.tar.gz 13606676 BLAKE2B 8183a757067d531bac4a959d770e619b6b9ccfc629e39a8b7ee9cc372aec518a056c7d0c27016103b2e535174046a4387e9719d0e9b749a8c4ee32b610f82211 SHA512 33b4ae7b5c5336140be7eedff82f112e3830bbddf835042b1ea7b95e643fe7e8943c38e80518778be122c1ec76d151af870df9afbce011438b38c13f967d4e4a
EBUILD trimesh-4.4.3.ebuild 2034 BLAKE2B 28b0063eefd036c6d882d0907b04eed1abacaf1206be8677b9e72c5e0d479bacbce43150227383ac9d2163b65f6dc405456e7064642f34f3c3d9b93e17964935 SHA512 624b55d78b99eddaf8e3446cf07d04344fe83c1f4b3033b75c076841f721e2bdc798e8b5e8cfddbc01db1d9e36f7232f5ff9145325c5e82bd5faea34b417ddfe
EBUILD trimesh-4.4.4.ebuild 2036 BLAKE2B fdc3533e944166ed99e70415f599e526e0a0eef5408ebea3e794a308ad5f2d98301a7984b9ad7570cdb939fcc528a3b01c9d6f8247cb195b54a4a4af338cefa3 SHA512 ff6e93c70c01ba4a711610db9e2a4ab818fdd4a78d9dbd35e410ac1fb3519a9358625fc0c5529eb95411a7329f56349c76b1ffe8c5f3c32ca1ca24add807fcbd
+EBUILD trimesh-4.4.6.ebuild 2036 BLAKE2B fdc3533e944166ed99e70415f599e526e0a0eef5408ebea3e794a308ad5f2d98301a7984b9ad7570cdb939fcc528a3b01c9d6f8247cb195b54a4a4af338cefa3 SHA512 ff6e93c70c01ba4a711610db9e2a4ab818fdd4a78d9dbd35e410ac1fb3519a9358625fc0c5529eb95411a7329f56349c76b1ffe8c5f3c32ca1ca24add807fcbd
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.4.6.ebuild b/dev-python/trimesh/trimesh-4.4.6.ebuild
new file mode 100644
index 000000000000..37fd5b19ad93
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.4.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}