summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
commit66520d3148e31806a52cf7df5b8d91d5cd431670 (patch)
tree15d0c80d9ee1b1e2a454a9930a03e3d3b7c6cc61 /dev-python/trimesh
parent0e82736d0df44565875b055019ded1be0ac5c319 (diff)
gentoo auto-resync : 17:01:2023 - 07:14:19
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.18.1.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 8f085f71a176..edb7abf22861 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.17.1.gh.tar.gz 12653345 BLAKE2B df286132ca01e1a7e8c226b7c98ffa0682b9bf2e225c4114c88395611d1a65a02be4395940ad04b67ae3b6909664b46e18e9fd018d892c86f8f5a4fcfe532210 SHA512 8cbf0bedd21c0867c5aa307e9bb8b4e4caff2aabee89cfadfa11513293304caa4b6a5ecce21064b7fa157a2453b58d401eb6010d0ea32bbd5a99c3075f38b826
DIST trimesh-3.18.0.gh.tar.gz 12656666 BLAKE2B e183ab1b5ff904b54a7801aaf9e6a3ac24a277107dae03dd37be7a37c56835ac99b617af1c12ea4119c39c3c064d8d1e783ce6effa51ebc0bc65103e688ad363 SHA512 309e1c5dd17a2d1875254a732d96708b98635cbd17ceea80c5386d6ea4675f943e1760f7a4383e9c24ec5711d30ea0732883a691952da1d1079a81a87fcca6cc
+DIST trimesh-3.18.1.gh.tar.gz 12657109 BLAKE2B 8e5370193e7d47f1dc2d7d43c356df1a56c2b4b8af6f47ac6aa889b04a3b950ec507b5cc0fe6f99f874cf66111aa72773025ba3821013466bb34baced3a361ca SHA512 72936c0fc6f89ffa35b80928dc5abac8ca4fac023f5be1d4adec6d020f3da6ee2c7a97efb0cecf58faad94ef6f33949533ac789affcecee07696ca0188fd47f0
EBUILD trimesh-3.17.1.ebuild 2217 BLAKE2B c230c692f86f17a22476b07c9f53932898002623f262883eaea2bb0fc6eadbf8a13df593aff9fb10081aaed92c6140c70608d92688cd4848b868611d69c6f936 SHA512 720f8b517b3ee4339d66f1e47c787b34fa52036673a458de0ca71ceb5a02dae0f3fe46c3e859d3864891becd88fc7dec69b7e8bd58044737bdef5646ed5832b2
EBUILD trimesh-3.18.0.ebuild 2218 BLAKE2B f49a7af8e9d99bf1885d340362bcfb9a198f8c3936c1b56717c68480826b6e7e51275a07dd247b896bef7c6360abae9a8a29dbe22825a4358718272c15f152f2 SHA512 d23a9b851923023216afc68fd53c41fbc82fb37729fa0f6491e111ca61f999fe0255ef209bc76411fe099516b87bebf174c426021f102ff24f13aa556ba616c0
+EBUILD trimesh-3.18.1.ebuild 2218 BLAKE2B f49a7af8e9d99bf1885d340362bcfb9a198f8c3936c1b56717c68480826b6e7e51275a07dd247b896bef7c6360abae9a8a29dbe22825a4358718272c15f152f2 SHA512 d23a9b851923023216afc68fd53c41fbc82fb37729fa0f6491e111ca61f999fe0255ef209bc76411fe099516b87bebf174c426021f102ff24f13aa556ba616c0
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.18.1.ebuild b/dev-python/trimesh/trimesh-3.18.1.ebuild
new file mode 100644
index 000000000000..982d211c51f1
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.18.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ <dev-python/pyglet-2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pyinstrument from tests, as only used for profiling
+ sed -e '/pyinstrument/d' -i tests/{regression,corpus,generic}.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # does profiling with pyinstrument
+ tests/test_scenegraph.py::GraphTests::test_shortest_path
+ )
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}