summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 13:50:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 13:50:54 +0000
commitaec6329fe6b56821fd643ccaacb4d5d61f4eaad6 (patch)
tree8c6e7db4b9a4a624121681a167e21bda8e3cfeec /dev-python/trimesh
parent0c8ede87a5d0aa1ec25364a435296ec7aa8b9634 (diff)
gentoo auto-resync : 20:12:2023 - 13:50:54
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.0.7.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 17a5cfd12ff6..c723639e9724 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-4.0.5.gh.tar.gz 13433920 BLAKE2B d7979727f4595dedd4d58bd7373bff457e008ea9512fb5aaa3c0e297fb0e9e538ab3b62e6d231bb6d0d7c8499e346c88b89878489187248bfd77116b4ab733dd SHA512 5167f93aece58d0fd2766a41afb5651df2ffac6486e3aebae33d97ed1ae2e4093290450b1e8d7827c300c679cf4c93baf7ce44ec603103a70c510259f514d321
DIST trimesh-4.0.6.gh.tar.gz 13434966 BLAKE2B ddb83647ffb9e268060662c2498bfe3abef423ea8fff6fb0a3d8f2677ff74222f008ca983363a16dbb833c357c8b16f3e92a6968dc79aed5593ee24e23dea076 SHA512 1b6d6be5782a44f58d16060247fe7842a30458fb5b1a01702ee224cd56a4bb3710954166373ec209de960ad6a77a649c44f51a59d31806a034bc6e7d8dca9319
+DIST trimesh-4.0.7.gh.tar.gz 13435408 BLAKE2B 72c9bf419e8a2e74f80922cba41cd999b6245e2376b38034b31d3741b9c9095ad578b46a45f02986f4735fc31086751f6eff1ac49f22af50c7061bf815550e62 SHA512 fcbc6cd917d1b6d0d23064efe6c484c8f920e966c9108cc9664cea502d43abc4cd3fb77cdd54491bb3098efae964910a9fb211aef763f576cf0ab1ae1267f657
EBUILD trimesh-4.0.5.ebuild 1813 BLAKE2B 215898d14db50b6817137f6bc7d23919c7facb6590c8481730f2907014add4c492b644ba754bca2b5b484804a5b0ad43eb2c652f819c39935099de59daa2f8eb SHA512 e5648bea2269b2bdd5971cad47e0c6624404e787d69a2389ffc019916a57ebfa468de56567501c4adae6ff06fef156698be7b3cda0017472bafc61d5b7f70996
EBUILD trimesh-4.0.6.ebuild 1815 BLAKE2B 42cc77b0be807b7ee938db86ab84521e7d718f6ef4e21294552839be74aaf30bcd980dcdddfa0172015e33bcf738ef916c259943a86294dbcc08addf3a06f963 SHA512 b83a81badf1b5519824f0b1e1aaad08cfd096ebfc5630f5bbfa6bdfc0708e49b6f303efbe4da3bc55c0e843b375cdb3fa323424898aece2cfc7d36b2197a5ce6
+EBUILD trimesh-4.0.7.ebuild 1957 BLAKE2B 4e7f4c14e20c83fe87a261696761bdc3cf6e1db5178e72b7f3118a2cb5919ceb50eaef70e8ef65e1198c55249a131058f036aa171c1111b26f47b301e5c73dca SHA512 9d8dba4fb7ab33e1260eabe5b59903daa00f6f7515da286af676ac4af75d6d559472681666cb3a2b0a5cfe3d2c8bfee955055b438a264eb18c841d9881824781
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-4.0.7.ebuild b/dev-python/trimesh/trimesh-4.0.7.ebuild
new file mode 100644
index 000000000000..4a40c4a6730c
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout --timeout=900
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}