summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 11:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 11:38:53 +0100
commitc53e4600c18a19ae2aaab501c1e5e7d6ceed23fe (patch)
treecc5e0068db67486f497b7bf5299b078899b39d94 /dev-python/trimesh
parentb31d1d6a72f3d27f400fe6c0781a620780f2627e (diff)
gentoo auto-resync : 08:05:2023 - 11:38:53
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.21.6.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 578fa60e7c06..738aedc793e8 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.21.4.gh.tar.gz 12692752 BLAKE2B 47f83c594318270c1594bad9c877de2cba71d44eccae7f755418aba785ce21c36946e482b38020a79417c4e346cd60cf3b31ee96bd489501a9dd88c2d433c68c SHA512 749f208b91f55b2a9581fa953bd984fc71a7c54bcc3d00ad1df8af2489911e966d2821dcff3d673e8ba55a83c9cce75625aaaeeddff817a16bb09b82b2bca549
DIST trimesh-3.21.5.gh.tar.gz 12692813 BLAKE2B 31f3933b4b76f55783dceb32b8079383d84439cc0705ae47b5e0062a8192a88123264ce0a803cf4bba6f3c0fad12b77cf524bf03b2ce5c1b2b4f6146eebcddd5 SHA512 4bf6879294042aea9bce65a79c1717de1bec92a0a9f6f420ed98dbc4cb5260dba4656ee0074f77d46d37c910838c7a4b7c7dff0249aa38109bb677993f886291
+DIST trimesh-3.21.6.gh.tar.gz 12691963 BLAKE2B 518d8d73268ed40f03fba48fb1e07f5ccf8801bc779dbe99261670e61f291de5f549a078de5de392da2754b08735eb7bcfe9716f541bde94296e6f48edf2e44e SHA512 65b348d334f7770f74e48bbed15f613b71fc0ba101c51a868bcd6becd315aa4a13f76722b2de84f6624b37b4d617dcc418f92ab19acb5e7f1992834bc0a5b96c
EBUILD trimesh-3.21.4.ebuild 1870 BLAKE2B a563dea7d00401f901d5551ff43ebe8abf7de18b74ab906c0bf55a7819132b57903270654c48f4694ba37fcd64c481482548a9bb4aa3e01999196de2659d34aa SHA512 0a4c0d01cfe7322d508ed8a0839f4ec42f4d0d8411f7f7a1c30696999e8424e2c4cfda76645dcfd809f2ae1cd4858484ff2bc5d02b565ace1a30571f115a75d8
EBUILD trimesh-3.21.5.ebuild 1871 BLAKE2B 820db5de2d19e1ff038ca7f2b716f0a526d8d710dbeb6417f4179a58f65d13d072443410c06087bda2f65d62b6f054dd56f1a95ca9c01573dbc650f55cb79680 SHA512 23e4ddebf3df5da330528d05007ab5b26d2ed534851a0fa7abbb28270e64a215bc32be2584e0e86b11884980d449c62be83608bad7bd9df6ac8385880339ab94
+EBUILD trimesh-3.21.6.ebuild 1871 BLAKE2B 820db5de2d19e1ff038ca7f2b716f0a526d8d710dbeb6417f4179a58f65d13d072443410c06087bda2f65d62b6f054dd56f1a95ca9c01573dbc650f55cb79680 SHA512 23e4ddebf3df5da330528d05007ab5b26d2ed534851a0fa7abbb28270e64a215bc32be2584e0e86b11884980d449c62be83608bad7bd9df6ac8385880339ab94
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.21.6.ebuild b/dev-python/trimesh/trimesh-3.21.6.ebuild
new file mode 100644
index 000000000000..c876396fccaa
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.21.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}