summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-08 12:38:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-08 12:38:45 +0100
commit14866757225815b9374acfc8453518951e0f910d (patch)
tree3fc69d84de25c5d40515dc05fdf5c5934ed69955 /dev-python/trio
parentb8c7370a682e4e29cda623222d17a790c01c3642 (diff)
gentoo auto-resync : 08:08:2024 - 12:38:45
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.26.2.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 257d7db348a7..2ea4fcf5b1be 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,5 +1,7 @@
DIST trio-0.26.0.gh.tar.gz 609710 BLAKE2B ec263e5db731760472111b8eb6a7d6ebdc476f8dc0976787692289caa5d5361a1a3db03d4713f14ee3198ad45dcec19c6c672af4af3860c3cd7ad5ff3e13bc8a SHA512 9a51f4e71795083ffd4a606e989583b1a93e45dc32f93d2d03bccaf32ca62a82daaf964676636363711b7ea1675dddd3eac1acae1be73b0fc570baef3c37c748
DIST trio-0.26.1.gh.tar.gz 610304 BLAKE2B 3bd9cd09cef7fe5484025ff2532c45a4a38f1c19b64ae833ecac5eda61463184a18020215dc569e40d1ec9950a860cf371ea461ac4d5b2dfc0f611d093c1ae7d SHA512 415bb701183e1a38574770e94c30fe4893a5f0be80291decf4524fc27677c12455124b3f7a03c37be89d42cb67b75e3315322f0cbf23264947d51ae251b3204e
+DIST trio-0.26.2.gh.tar.gz 610516 BLAKE2B dfb62a4024f2e42243dff6bea97ee3657c1975ff8d081010efe1b0fd3962a3b1c4847341df1028e2c902a043d0b43b6190ccdd72d5bfdb6e650912034ee56c28 SHA512 0b6fda127937de5c13eb12aea4ad5f95b4bfcb839c1a65c25a563aef6450bfb35c24af3509043eb389472e414549fbc9d40e64c8aff068cb34ffaf8b29fe9c67
EBUILD trio-0.26.0.ebuild 1750 BLAKE2B 6ab9bba94af5a7ca9fd499781d61c35540593668476ae7a6491aad954ec011eb0d3ba10a66d1038ec3b940dcac7027372de3dd8f112268cd4bbdd427e1145046 SHA512 305326aba005a7b09fc727db6d529b45487dbf2b93803a5c7dfa5dedb9f74d47cec8bb04ec3547c170480412f2fa2d40ac277a871ff4d527a86775d1f994fc72
EBUILD trio-0.26.1.ebuild 1757 BLAKE2B c9354d0d68f61919d0c0303a4f589cddfb89749f5f878b443efd588de9973fc603b1e9068e2924f1d23b0bdb13c98039a4782def2066094fd5b8dc35adcce9ae SHA512 ad74bda9a451180e4d6aacd87761b7f16e39e49388cc41902ed00bd454a324eed697f08cf5300c66fdfcf14a391a531000a7631a4d5834d1ae74e31ef81f3660
+EBUILD trio-0.26.2.ebuild 1757 BLAKE2B c9354d0d68f61919d0c0303a4f589cddfb89749f5f878b443efd588de9973fc603b1e9068e2924f1d23b0bdb13c98039a4782def2066094fd5b8dc35adcce9ae SHA512 ad74bda9a451180e4d6aacd87761b7f16e39e49388cc41902ed00bd454a324eed697f08cf5300c66fdfcf14a391a531000a7631a4d5834d1ae74e31ef81f3660
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.26.2.ebuild b/dev-python/trio/trio-0.26.2.ebuild
new file mode 100644
index 000000000000..01b349cf4ec8
--- /dev/null
+++ b/dev-python/trio/trio-0.26.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Bug https://bugs.gentoo.org/916756
+# distutils_enable_sphinx docs/source \
+# dev-python/immutables \
+# dev-python/sphinxcontrib-trio \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+ # requires ruff
+ _tests/tools/test_gen_exports.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf trio || die
+ epytest -p trio._tests.pytest_plugin \
+ -m "not redistributors_should_skip" \
+ --pyargs trio \
+ --skip-optional-imports
+}