summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/trio
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest3
-rw-r--r--dev-python/trio/files/trio-0.19.0-python3.10.patch25
-rw-r--r--dev-python/trio/trio-0.19.0.ebuild36
3 files changed, 51 insertions, 13 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 39f364bcb11f..fb81f847a249 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,4 @@
+AUX trio-0.19.0-python3.10.patch 967 BLAKE2B 78989da73496beb5058feedb8218a718b67dfe5b2bb3d6f975a89f972f14f2ac6cb4a21e1beac626aeaf9b4d8678b54a4899cf9714962309c241b4d09e08f17b SHA512 c1e01e0a1b74132cd2421def3c8e78d777e1ae45aa3b8abe234ce4212182769df3241c29ccbe173ba17b247dbc84edbf292cc38e5f9d7c2c8984816197efe669
DIST trio-0.19.0.tar.gz 486036 BLAKE2B 052cadb8d251960b20349659b92f4d26c5b65128cbbfafee21a4a4b90463e43d9c9db6b35f3659d2b062c7d0b8b8914b31b38d2faed6c9d948c0ccbe85a0a250 SHA512 5297a3f48b786eac05b686f1e8bb0603a9c0133d6c4872a307cdc8f1e37aedb57d668b61c2568c82b7d1058b6604a22d2c5c2298f13d13f0daf8e9259aa76d7c
-EBUILD trio-0.19.0.ebuild 1469 BLAKE2B dfb55b55f03cf08eddf9d6849167d0c9e92a84a7473836a39e9cc05ad5766c161cd5cba17081ea2f4d04c146eeb19a571ab671ff5e9ebb48e3635436d59ffa5e SHA512 7e641ca81eabd798aa21dc07aaffdd811c414e65e9c23a0996663e833ab35a62eee68b8e4b1db5e976e7f01ba5401e5ea30146741c1b6fcebd719427f2ae9aa6
+EBUILD trio-0.19.0.ebuild 1877 BLAKE2B b2c6229033d38538835aa347d95b701c1a30ed6d859a43620c000c2d2b1824387281e0bc7f160a22c08c339c73140fcd5839fb0dabc8e91199cc0a1949b0fe1e SHA512 9a544a686b564b82010adcd93076306f12e9a4749c7dc07fed656dc401add9ce6f049f04a7f0de14bbde5081befd7676731721a587ce7e2532be4082da2a2fc4
MISC metadata.xml 1959 BLAKE2B 8b8c53b057e11c334de01db932a4b7cb9dba98c200142765224af1252be7e3e756ebd2e8c1295212d8930df2afecafdaf252375e3e842c58d8149432ed038606 SHA512 d7ad911af38df2e7ef4e0659b3a8abf25c334e10d0a637c1d901a05e517e5caeee68932e4263c1bdedbee6af6e15b80cb1bb377ababe4078a507fc5096073b1a
diff --git a/dev-python/trio/files/trio-0.19.0-python3.10.patch b/dev-python/trio/files/trio-0.19.0-python3.10.patch
new file mode 100644
index 000000000000..45af8955df3e
--- /dev/null
+++ b/dev-python/trio/files/trio-0.19.0-python3.10.patch
@@ -0,0 +1,25 @@
+https://github.com/python-trio/trio/commit/0a0b75c914e63366f23790d72caa10bdfcc186f6
+https://github.com/python-trio/trio/pull/2061
+
+From a9c54747b90129776f6d2d384e0f64efaac324ee Mon Sep 17 00:00:00 2001
+From: "Nathaniel J. Smith" <njs@pobox.com>
+Date: Tue, 13 Jul 2021 17:34:26 -0700
+Subject: [PATCH] Export IP_RECVTOS, newly added in python 3.10
+
+---
+ trio/socket.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/trio/socket.py b/trio/socket.py
+index 5402f5bc7..afbcefa1d 100644
+--- a/trio/socket.py
++++ b/trio/socket.py
+@@ -117,7 +117,7 @@
+ J1939_PGN_MAX, J1939_PGN_PDU1_MAX, J1939_PGN_REQUEST,
+ SCM_J1939_DEST_ADDR, SCM_J1939_DEST_NAME, SCM_J1939_ERRQUEUE,
+ SCM_J1939_PRIO, SO_J1939_ERRQUEUE, SO_J1939_FILTER, SO_J1939_PROMISC,
+- SO_J1939_SEND_PRIO, UDPLITE_RECV_CSCOV, UDPLITE_SEND_CSCOV
++ SO_J1939_SEND_PRIO, UDPLITE_RECV_CSCOV, UDPLITE_SEND_CSCOV, IP_RECVTOS
+ )
+ # fmt: on
+ except ImportError:
diff --git a/dev-python/trio/trio-0.19.0.ebuild b/dev-python/trio/trio-0.19.0.ebuild
index 9cc46ddc68a3..b02ca40ed6e5 100644
--- a/dev-python/trio/trio-0.19.0.ebuild
+++ b/dev-python/trio/trio-0.19.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
RDEPEND="
>=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
@@ -26,29 +26,41 @@ RDEPEND="
dev-python/sniffio[${PYTHON_USEDEP}]
dev-python/sortedcontainers[${PYTHON_USEDEP}]
"
+# NB: we're ignoring tests that require trustme+pyopenssl
BDEPEND="
test? (
>=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
>=dev-python/immutables-0.6[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
>=dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.10.patch
+)
+
+EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # Fail with Python 3.10 on 'IPPROTO_MPTCP'
+ # Everything else passes and this is a simple check for exported symbols
+ # Let's try again with the next release (after 0.19.0).
+ trio/tests/test_exports.py::test_static_tool_sees_all_symbols
+)
+
+EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+)
+
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source \
dev-python/immutables \
dev-python/sphinxcontrib-trio \
dev-python/sphinx_rtd_theme \
dev-python/towncrier
-
-python_prepare_all() {
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}