summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
commit2f210c93c08515a806199783aabe37d12a0197cb (patch)
tree8b846898d136de0503e4ec3c2cf1f90660ee3336 /dev-python/trio
parent1c19f0d8d940b35f723e28d8a6ebe388cfacd1d8 (diff)
gentoo auto-resync : 30:05:2023 - 21:21:38
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.22.0_p20230530.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 007bba1d77e7..51442dc103d9 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,5 @@
DIST trio-0.22.0.gh.tar.gz 517482 BLAKE2B ab1fcb22d8f0ed9c8de831a9384b55ab433811863974cb767cb0ea4eb3a0df7372b5ea2c2d4c2af3ca1d3c8c3144d5546ad8cc68276b17ecb3d20ea1858ba9e0 SHA512 45b813d6cc65f8d49f70cb0ea7f33593fed0cc5989c60ba449f0b38c4759604aa7360cd016758fd364438b92516be549edf1efd583c7f5ee2de8813334f182bc
+DIST trio-93c1d96a535cca565e1b1ba552cb9c4798b3f852.gh.tar.gz 528405 BLAKE2B b6db1413259c7aa4aa9055eb8d0d810ca7866e312ed81395c7bd2d69cad56dec9cd1422513ee4018077eca0a3b55b4fe74178d4af3599e8ba8b7ad124d820066 SHA512 e5bdc6f918cac8d8eed5d459cfed368336eec301890bd6b579bdf3b2bca7d78246b5b06fb6259fadba0fef45b782e8b03c85884b96d8a961056f7720cd28b944
EBUILD trio-0.22.0-r1.ebuild 1981 BLAKE2B 2e5162f1bdfc90f7cca02210e461d99fde2c74e371f6002d2170f1ac13e6d399a4029ca486c5600e046f8d250ffb230b2075054780c33b87ffc41e988c33ac2b SHA512 a9e5e9a5f9b7bbe176eb369c296e8ec446f3addb53701f8f3c3d06463ee2a939a6c0434c0774ace874b054185baf6286f30d53bc90630d534f5ac74a42a59ada
+EBUILD trio-0.22.0_p20230530.ebuild 2094 BLAKE2B b0606066d679eaf374aaae3054aaf937c05b03314aad486bbb700f689626fd80803bafc540448e506a7d656ed4cfe21ad0574e325c52d31b6b39abab1f961ce4 SHA512 4623ee516ba2424acf4bf017859a14eae827ef725772af0f8242fce7e80283a6bd2a7a28462a85fe323df10b33580502bfe3dc8ec07eb022639e71cea1378b3d
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.22.0_p20230530.ebuild b/dev-python/trio/trio-0.22.0_p20230530.ebuild
new file mode 100644
index 000000000000..987eea446215
--- /dev/null
+++ b/dev-python/trio/trio-0.22.0_p20230530.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=93c1d96a535cca565e1b1ba552cb9c4798b3f852
+MY_P=trio-${EGIT_COMMIT}
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx-rtd-theme \
+ dev-python/towncrier
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ trio/_core/_tests/test_run.py::test_nursery_cancel_doesnt_create_cyclic_garbage
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio._tests.pytest_plugin -m "not redistributors_should_skip"
+}