summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/trio
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.20.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index fb81f847a249..052b080bceac 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,4 +1,6 @@
AUX trio-0.19.0-python3.10.patch 967 BLAKE2B 78989da73496beb5058feedb8218a718b67dfe5b2bb3d6f975a89f972f14f2ac6cb4a21e1beac626aeaf9b4d8678b54a4899cf9714962309c241b4d09e08f17b SHA512 c1e01e0a1b74132cd2421def3c8e78d777e1ae45aa3b8abe234ce4212182769df3241c29ccbe173ba17b247dbc84edbf292cc38e5f9d7c2c8984816197efe669
DIST trio-0.19.0.tar.gz 486036 BLAKE2B 052cadb8d251960b20349659b92f4d26c5b65128cbbfafee21a4a4b90463e43d9c9db6b35f3659d2b062c7d0b8b8914b31b38d2faed6c9d948c0ccbe85a0a250 SHA512 5297a3f48b786eac05b686f1e8bb0603a9c0133d6c4872a307cdc8f1e37aedb57d668b61c2568c82b7d1058b6604a22d2c5c2298f13d13f0daf8e9259aa76d7c
+DIST trio-0.20.0.tar.gz 491254 BLAKE2B 354e8019d1ba8ac35bbb00477806ab87d62de0e9a94b1ff3a4d63c024af8cd40261c46a2c9449f38550e809938f3c6ee620a47e866bc31203c3c4a4984446fa5 SHA512 9aa431d0bc28737dd48a7358446acaffbf34860dc467ac121166f7241ebf4a4ed8bcdc8dc0277034e3c3fd70f1f8a57d790e98bdda7a1141f2c53c6b85a97a3c
EBUILD trio-0.19.0.ebuild 1877 BLAKE2B b2c6229033d38538835aa347d95b701c1a30ed6d859a43620c000c2d2b1824387281e0bc7f160a22c08c339c73140fcd5839fb0dabc8e91199cc0a1949b0fe1e SHA512 9a544a686b564b82010adcd93076306f12e9a4749c7dc07fed656dc401add9ce6f049f04a7f0de14bbde5081befd7676731721a587ce7e2532be4082da2a2fc4
+EBUILD trio-0.20.0.ebuild 1856 BLAKE2B b4cc219897103ac2464f4a241afa68253deacc52db3c669b37c37207bf52d50bcb9e7ebe243615ce0ce12d843acfab9229076efd49d4b0184a4247e01c7b8ecf SHA512 4f8eb4e531e126ba478ba84770a9d1fa71f3df134039cbd2003060a62ec72bf7b3c304d62c35b18a0ca1833b28b5efccde4abf8b8d3c5e2b762d38751f4dc0ad
MISC metadata.xml 1959 BLAKE2B 8b8c53b057e11c334de01db932a4b7cb9dba98c200142765224af1252be7e3e756ebd2e8c1295212d8930df2afecafdaf252375e3e842c58d8149432ed038606 SHA512 d7ad911af38df2e7ef4e0659b3a8abf25c334e10d0a637c1d901a05e517e5caeee68932e4263c1bdedbee6af6e15b80cb1bb377ababe4078a507fc5096073b1a
diff --git a/dev-python/trio/trio-0.20.0.ebuild b/dev-python/trio/trio-0.20.0.ebuild
new file mode 100644
index 000000000000..4d8c69bb7ba7
--- /dev/null
+++ b/dev-python/trio/trio-0.20.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio
+ https://pypi.org/project/trio
+"
+SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+# NB: we're ignoring tests that require trustme+pyopenssl
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # Fail with Python 3.10 on 'IPPROTO_MPTCP'
+ # Everything else passes and this is a simple check for exported symbols
+ # Let's try again with the next release (after 0.19.0).
+ trio/tests/test_exports.py::test_static_tool_sees_all_symbols
+)
+
+EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier