summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-03 09:55:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-03 09:55:53 +0000
commita45825edc1b8bca4fffbc0435da0a8c898f44f36 (patch)
tree54003915c7274a05d5e7ebf2d2f037e86c6f8d2a /dev-python/trio
parent54e9f9704b37e05c561eadb37d89d30ee7dda9ee (diff)
gentoo auto-resync : 03:11:2023 - 09:55:53
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.23.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 86b701440ecd..5e8855ba1756 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,5 @@
DIST trio-0.22.2.gh.tar.gz 536949 BLAKE2B f469f306d826d110defabf14956bdfe390a0f36da16da7e6e0426573cc9faf8943514b67a22fa44463c35f1e02c61c4aa3fd8da6bc408339a77367953fc62be0 SHA512 c3f08b8a1a37c0a06e520c7c5cf6ab5ffa2366c0e8599ae831e896e79bb144ee13ea426c8e6d8278f4620eae15c3c3af6c46c8b4526147336e30050bbf111120
+DIST trio-0.23.0.gh.tar.gz 585629 BLAKE2B e8d3432dd199cf6f4fa174a92696e08d0ff2a75d783ec65c217a8049cba1132821503f783b85a89f629ca39b9278711af76df5431cd14ba319fc8654585a16cc SHA512 01fab7447f7e8cde3223077ef45a788d67df8348a44325c72209f14b48f4c8510de17fc88e8c02921568274907e79599061894a12987db76e33f84dd040c5e81
EBUILD trio-0.22.2.ebuild 1976 BLAKE2B 2f7c05a2235608e2850938d9ec1a6871cda68309d95d764acc1fdee6194b9fbcabaeb690ba41d90c0ec3c0453ad6404ff0010868a4fb79a7e905ce322d702352 SHA512 01f96539ee6a0bfc51184184df4c4e47be9ebfcb4ed394c68436791c505382a9ed47e990f46ef3bc22f5d5f328d2db8b9cab7d2b81b5ec3ade129f97e4b477e5
+EBUILD trio-0.23.0.ebuild 2042 BLAKE2B d0e66b47a63341b2e6f9873f1fa5c2bcabe8ea4ce580029d2a2f07468ae6298e64ebab4731dd756784c6e255f221c1ac93a0355a71315f2da78b883f90bf7399 SHA512 2bb8a6d231836cf0fc5eed08796c9893f96ac84d23a64c9dcc2ced4391652b2d2b1fe14766e298b5e3740e522c145c717e345133182cb59b2f18e887ee3ee468
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.23.0.ebuild b/dev-python/trio/trio-0.23.0.ebuild
new file mode 100644
index 000000000000..184d0483cb5e
--- /dev/null
+++ b/dev-python/trio/trio-0.23.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx-rtd-theme \
+ dev-python/towncrier
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+ # requires isort
+ trio/_tests/tools/test_gen_exports.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ trio/_core/_tests/test_run.py::test_nursery_cancel_doesnt_create_cyclic_garbage
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio._tests.pytest_plugin -m "not redistributors_should_skip"
+}