summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 15:14:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 15:14:06 +0100
commite4faa07b4eb2f5e4f9756d33924b318b1349956a (patch)
tree0bb828f26b3f3dfe1bc3ec06cf3c67c6c32085d1 /dev-python/trio
parentc50fa1b9d54c15707ec744b80db6610da7dd7832 (diff)
gentoo auto-resync : 28:09:2022 - 15:13:59
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.22.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 953bdea68325..89976a8a549d 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,5 @@
DIST trio-0.21.0.gh.tar.gz 491228 BLAKE2B e5f65d3aa9e4bc0c449e3986048d63fe3001a2eee96dbe5d8c088e0fce786b1d50861b47170baa7cced097938b16c92f0efd51518404a5e0ea6a17a48d656823 SHA512 383b11f264ddf4c78eb75829472826ebacf32d063790e8d4681d5df2f21c4f9287884db1752fd19976b674643adf7299816d4404e3032193ef90f522ad9cfa79
+DIST trio-0.22.0.gh.tar.gz 517482 BLAKE2B ab1fcb22d8f0ed9c8de831a9384b55ab433811863974cb767cb0ea4eb3a0df7372b5ea2c2d4c2af3ca1d3c8c3144d5546ad8cc68276b17ecb3d20ea1858ba9e0 SHA512 45b813d6cc65f8d49f70cb0ea7f33593fed0cc5989c60ba449f0b38c4759604aa7360cd016758fd364438b92516be549edf1efd583c7f5ee2de8813334f182bc
EBUILD trio-0.21.0.ebuild 1742 BLAKE2B 2767c2507e50c4be163201cebd1f573f1aebc5d585b7b5670d705268ce2b61a2c69788ec1e60d384fae1bd47990701840960cdcaf509a696bf091f9d76da5590 SHA512 443b76f264efba62737f5452e6c9a108ae4a3c31fde001a0c0ad540fd831dbb344c7f5bcb401b58e08f0a3afbe1df2ee6f9deec0a4eea9931eac98c85aebd6a8
+EBUILD trio-0.22.0.ebuild 1819 BLAKE2B e004e3ca903bad7fb923e4057ae4c62d1661168664fd36c696e3aed771bd1d95f3275985656e6087190f76d59d5bffad1404f96d363735c6f49b896759a52cde SHA512 5a4af80e7ffb4edea3c6fba72be9deb02f3e93a0a58a219b988c51617df4cbcefd6a4957580761dd7cdc22088bf7d109696ac4b8e6f7b47eae3b849918e2ecbd
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.22.0.ebuild b/dev-python/trio/trio-0.22.0.ebuild
new file mode 100644
index 000000000000..0762903a78dd
--- /dev/null
+++ b/dev-python/trio/trio-0.22.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+# NB: we're ignoring tests that require pyopenssl
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not redistributors_should_skip"
+}