summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.12.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}