summaryrefslogtreecommitdiff
path: root/dev-python/twill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/twill
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/twill')
-rw-r--r--dev-python/twill/Manifest5
-rw-r--r--dev-python/twill/metadata.xml11
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild51
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/twill/Manifest b/dev-python/twill/Manifest
new file mode 100644
index 000000000000..c77e089fabce
--- /dev/null
+++ b/dev-python/twill/Manifest
@@ -0,0 +1,5 @@
+DIST twill-0.9.tar.gz 242291 SHA256 8053c25fd6edf6ddf5e7583224e7b23ad947df1f90175b018af5cf7abeb42a86 SHA512 ea47400e236c4f5a4d38671bbc5690d004c4dbd20b6152c54c2fa64bae3e3ec68d16a5305d42e8631595cac25f5b2a08e0eb287b7e1ed7b90a8368d6063b1f1e WHIRLPOOL ee306acc4434b919119fa103d15f82909490b57440d61dc4193af3d11827759202949a8e568b356fcd52a34ec791f5f5adeedf7848471fe13f53fa7dbebc7ad3
+EBUILD twill-0.9-r1.ebuild 1195 SHA256 0753f94e5b0238adb6e5b7b6682a2f70fa244fd984be457ccba4c89be4fdf50a SHA512 56704686ef6c315d9acd351d5bdb40b01c16953a775d24e10f62946fadc882fee51cbae045aa609f4a22e9aaa540924903af90499084ebc80da14a81afe20fa0 WHIRLPOOL eed22e91abcfc6d9f8c71634ac33efeff2a652919f7611eecef12e2e9b2ea13808e550e2196fe6b1283e67d7a5b6b7955e867a78e3bbd7acac95486c08edc645
+MISC ChangeLog 3048 SHA256 40b00804c1565323983f5dbc7c6d82c8da807c959ca0ad5575211da7e415db7e SHA512 0b4d37603630d250d0a5598a9c6fe7f56899e9807ab3e8bdc6b7a1d63775aed7405de4f533e06e31f3be944946e13072584af15a84ade60a99e7838cf410952d WHIRLPOOL 9813c9f3d0711d4c84d621bdd09d62b19015298b8e5aebfc6c8bcd0f8ef4bc317698f9858da60f8da9035bf8f1b8c17268da8dec5dce7f32dc0d49afb4609648
+MISC ChangeLog-2015 2433 SHA256 e83143835d6e4cfd34d2c5b573c320a02a385791ce98f99b0104b132482dfea4 SHA512 0bc4b0419ec016c8e21d9e50caa270c72020d4c6828c7c1084d6305edd7d95618ed9f5b2c875124e904fc696ea260533b9282158f40e312830a8f670df978ecc WHIRLPOOL edbf7045b5d5dbbcad23a97dd7154601a24caf835ed23fb25d81a09f7d02907656a4af2f4a9625f926e1df538a2fef21a9151d09309ee57a1a18d9a02b844d4e
+MISC metadata.xml 630 SHA256 3a4ba61f7bff79c54cafca1934cf039639466bcf191ac997cf70ba094233aad5 SHA512 9d08bb18d5ff85f2301d2b1f2aff814cb63257c3fdd1b19d4fe72ce5060d9cbedd0c26a5f3fd55cc972f3c41861bea7df92584945b381b7e8f8caa3d7d97f39f WHIRLPOOL c961eba9a6e3f2980aa91cfa8fc488df4f3174e921649237d017a01633b60048066f734d6eef821b5c325d8ed9bd4b8b6890db0ee33fb3eacb8ef23c3143fae1
diff --git a/dev-python/twill/metadata.xml b/dev-python/twill/metadata.xml
new file mode 100644
index 000000000000..99a143d0daf5
--- /dev/null
+++ b/dev-python/twill/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ twill is a simple language that allows users to browse the Web from a command-line interface. With twill, you can navigate through Web sites that use forms, cookies, and most standard Web features. twill supports automated Web testing and has a simple Python interface. Check out the examples! twill is open source and written in Python.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
new file mode 100644
index 000000000000..127b1b3cfb74
--- /dev/null
+++ b/dev-python/twill/twill-0.9-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Simple scripting language for web browsing with Python API"
+HOMEPAGE="http://twill.idyll.org/"
+SRC_URI="http://darcs.idyll.org/~t/projects/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="doc examples"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'virtual/python-dnspython[${PYTHON_USEDEP}]' 'python2*')
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup 'python2*'
+ pushd doc > /dev/null || die
+ chmod +x make-epydoc.sh || die
+ ./make-epydoc.sh || die
+ popd> /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/epydoc-html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}