summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /dev-python/twine
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest4
-rw-r--r--dev-python/twine/files/twine-1.11.0-tests.patch18
-rw-r--r--dev-python/twine/metadata.xml12
-rw-r--r--dev-python/twine/twine-1.11.0.ebuild40
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
new file mode 100644
index 000000000000..42e5012cc411
--- /dev/null
+++ b/dev-python/twine/Manifest
@@ -0,0 +1,4 @@
+AUX twine-1.11.0-tests.patch 432 BLAKE2B f912ae6e51652c299d4b99f2db69f6daa309f0a04e89205fa207e6ed8073c84b212ac6c24a344850b5d11e9a55eb0e6924c0c3306517726c262df1c298114c2e SHA512 a997ca1f2d077a3a23374bc816cc4d6d295c8912a3a28fa6bc404891fe6699e88d98febcf8867e137906b4e5994ab73ea0899fd5045768f30f482d845b295f6d
+DIST twine-1.11.0.tar.gz 55301 BLAKE2B 88e88bc88a6dc8320064b3e296d85f1614d1ecf1628c8442737566ac58c3296b2292f147c0b39047a1d13a3ac98297fd7a77a0ba6fdb6ff04e59d16bc8ed463a SHA512 28e588f26b59bc9f4a8481caf2353934ad6927734762ffebb4416c147ec9e6dffb37092def20a76eb888c94b27f97e013dacc42c63e5dcda30f4290bb6c90a22
+EBUILD twine-1.11.0.ebuild 1167 BLAKE2B 85fdadb933fdae6ebe7901cf9346fa0d3c38f3cd294f54491457d59dcbee4f4c4a2a74deb18f9c12b6edce2f26b49fad9c9ce84dbfb1d6f1531b4c1874cf555c SHA512 37e54167c2f2e0343ca1ca7d54c243fa576eccdb8853788e8090107af09b229b783e79a5baba191c5d942056570517bfffc42c3b3ceb9bba2b20a242e0227626
+MISC metadata.xml 358 BLAKE2B d4ec540be4b2496c1067200781bb8be0cc085bb4d85f922bd1bc66cd24e4514ba2ba7e8653e3c9dabe7295e24241e4de6c22701eb40328393ada4bcbfa7d77b7 SHA512 525abc4d0649347e2a0c121172aa16b94560d549a37d81712513e39e67046748d460bf07109baa373bc261938f79456ae81f361fa0d41915edb32382bc61de17
diff --git a/dev-python/twine/files/twine-1.11.0-tests.patch b/dev-python/twine/files/twine-1.11.0-tests.patch
new file mode 100644
index 000000000000..386a4ebcf3ab
--- /dev/null
+++ b/dev-python/twine/files/twine-1.11.0-tests.patch
@@ -0,0 +1,18 @@
+Check for python2 support first, then python3. This should help avoid importing
+the wrong module for python2 where the builtins module can be provided by the
+futures package.
+
+--- twine-1.11.0/tests/test_utils.py
++++ twine-1.11.0/tests/test_utils.py
+@@ -19,9 +19,9 @@
+ import textwrap
+
+ try:
+- import builtins
+-except ImportError:
+ import __builtin__ as builtins
++except ImportError:
++ import builtins
+
+ import pytest
+
diff --git a/dev-python/twine/metadata.xml b/dev-python/twine/metadata.xml
new file mode 100644
index 000000000000..3b7872fa6a97
--- /dev/null
+++ b/dev-python/twine/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">twine</remote-id>
+ <remote-id type="github">pypa/twine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twine/twine-1.11.0.ebuild b/dev-python/twine/twine-1.11.0.ebuild
new file mode 100644
index 000000000000..053b8a767636
--- /dev/null
+++ b/dev-python/twine/twine-1.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.python.org/pypi/twine"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarballs don't contain test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5})
+"
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+python_test() {
+ py.test -v tests || die "tests fail with ${EPYTHON}"
+}