summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/twine
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest2
-rw-r--r--dev-python/twine/twine-5.1.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index e632c368adaf..4f224058421f 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,5 @@
DIST twine-5.1.0.gh.tar.gz 221527 BLAKE2B 45b707883e84ade7cad8bee712e7b68f24eb8ccfd018de5c0522cf98cb66895e6a4324f17e54fa87dacdf97ee092a0fdbc0b5289b30871da36828c987c518c2f SHA512 41a5b94b6929a0a018cd15dd4ede45a361420752235e9b1a8b16979609e6a056bf46cd88efa869c27fa9bae3907f4e45d0c468de8058c3f82f15b48b4274b4cd
+DIST twine-5.1.1.gh.tar.gz 221931 BLAKE2B a95d50e52bde5db64c6ce5b57097188e9cb88763c91f337c3e552ca34bae34882d87bced4b0c55a292de185fce10384edf514b55373c4456ff252471076bcb28 SHA512 95f059235e32134a5320c0835befa2eed6eff35c56685afe4848224042c2e2af484db72f20fd0cfbe979cce8d495e8bb2d2ea38aca2c53ca7af8de378816bedf
EBUILD twine-5.1.0.ebuild 2094 BLAKE2B 2aeef10d14879faa33fe5ea60dbb35e2a995b3b514a69e19261f07cb16de98f736419f273c59169178a40da36d0ccdb9200a7e7f80c7d3a61b88f4af249de957 SHA512 8b23211247dd349263488ebd17b10779b9bef12420a96900cf808a7dc8b5edc847dd294b4030b96842316b62d518ceb845c6813c300f39c8895f763c2a010eb8
+EBUILD twine-5.1.1.ebuild 2238 BLAKE2B 752eb6638d07fc67709d420e7f61168a950b875dd25cda50314cb4766576e12dab0a81ad611b4beda4e4ab0dcdf4a8e87f7fd2aee7f971663aad11f48b4eb5af SHA512 21b261ae8edd63b5649b6990e6e41b9771a42135243cf5eff390f2ea0855d290ea7e8cfa47c725db586752ed6dcc9d2912510fe4cefc9382c76a4d1c98a5ed76
MISC metadata.xml 383 BLAKE2B e2a596604a2f3e40ddd0196ea79105e318f8a04d9e5a2c7e458d403d215af1371f2a526fa7d8cbc430f20747f7b65ed6c8546263fb8a54ddd8a6db487c358634 SHA512 cd5c1f1ed89dc5c314975fc5b503108d6828db37826ebba98d6edd580b72cd41867e19e65a9a022f8c07babadecd810f21febeb8a015c51eecec412b9df4f0d5
diff --git a/dev-python/twine/twine-5.1.1.ebuild b/dev-python/twine/twine-5.1.1.ebuild
new file mode 100644
index 000000000000..764cc9a11109
--- /dev/null
+++ b/dev-python/twine/twine-5.1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="
+ https://twine.readthedocs.io/
+ https://github.com/pypa/twine/
+ https://pypi.org/project/twine/
+"
+SRC_URI="
+ https://github.com/pypa/twine/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/readme-renderer-35.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Internet
+ tests/test_integration.py
+ )
+ local EPYTEST_DESELECT=(
+ # Regression due to deps?
+ tests/test_check.py::test_fails_rst_no_content
+ # Avoid needing heavy virtualx
+ tests/test_auth.py::test_warns_for_empty_password
+ # https://github.com/pypa/twine/issues/1116
+ 'tests/test_package.py::test_pkginfo_returns_no_metadata[unsupported Metadata-Version]'
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}