summaryrefslogtreecommitdiff
path: root/dev-python/twisted-web/twisted-web-15.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/twisted-web/twisted-web-15.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/twisted-web/twisted-web-15.2.1.ebuild')
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
new file mode 100644
index 000000000000..25e20b15f996
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite