summaryrefslogtreecommitdiff
path: root/dev-python/txaio/txaio-23.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
commit61f62e5edc868fc4ae3b92af397397ee5056578a (patch)
tree81261ca75a34aa85973eeb3cd828878c4e72bcee /dev-python/txaio/txaio-23.1.1.ebuild
parent433cb2e828d414c74b16d429f40d25e179b0a70f (diff)
gentoo auto-resync : 16:01:2023 - 11:57:19
Diffstat (limited to 'dev-python/txaio/txaio-23.1.1.ebuild')
-rw-r--r--dev-python/txaio/txaio-23.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/txaio/txaio-23.1.1.ebuild b/dev-python/txaio/txaio-23.1.1.ebuild
new file mode 100644
index 000000000000..8a5a87523478
--- /dev/null
+++ b/dev-python/txaio/txaio-23.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="
+ https://github.com/crossbario/txaio/
+ https://pypi.org/project/txaio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinxcontrib-spelling-2.1.2' \
+ '>=dev-python/sphinx_rtd_theme-0.1.9'
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # we certainly don't need to test "python setup.py sdist" here
+ test/test_packaging.py
+)
+
+pkg_postinst() {
+ optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
+}