summaryrefslogtreecommitdiff
path: root/dev-python/txaio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/txaio
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest4
-rw-r--r--dev-python/txaio/metadata.xml6
-rw-r--r--dev-python/txaio/txaio-20.4.1.ebuild49
3 files changed, 55 insertions, 4 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index ac6919e5c535..a708d8ab2bfa 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1,3 +1,5 @@
DIST txaio-2.9.0.tar.gz 44195 BLAKE2B 6c62fc6f17ee860aead90cf5f5d02c7c0d9709adf7bcecbb6a7c1723abf0d8672dbc0b869dfe4683bc26c9608e94c41364add18c22e8e98678de8e10018d991c SHA512 ee07d776fa5894b716fdced36aaa6436336a1f1db97dedb0fd0575d61a7b48b12dfc90ed6078602d7a2c2a00bfa7f815ca76cd75e472a27ff7bfdb56291efa46
+DIST txaio-20.4.1.tar.gz 52580 BLAKE2B 28d745eb9e8a0df1ca8748ce455eb122e240505f31464fcc0e66bafcefa8a01a356e44a46d9a5a1b1c670df46ca0c2ea9e66d29436bf2668e5614c5aa8726cee SHA512 da0269d13d72f4ea14f2e67585cdb74ec5105884c31d81157fb85e92d4eb935b1c13eb1222bd5ecd57a8caa36008cf49de85321e7b67e94159330e1d592d42c4
EBUILD txaio-2.9.0.ebuild 1277 BLAKE2B 6d2ba58eed43d55a7ee40cbc3b1e4e604b45712796ad8f156e17c155edca9ca4a17961132770a8f44bdbfe3b26738f86af1e646c00297c6c839d672910b1609d SHA512 85b98df51df9b0766c2f07a62ee5b90c240c8d8c8d0ebe700890701db5e05bc06bd6a84ede19c811bf47e1218dd78c72003df52c7025b8720d6c4406e2137dcb
-MISC metadata.xml 487 BLAKE2B e04a40627282564f381f0070344ba6e2a08e572121e150b5775239dacf22212fb273253dae6ad19ba2cea7f15e84c7f92c6d0671353b2d159b9e7f40d3415914 SHA512 d7eb59861e36e29555d46c3a65814428e64473abff01b6d5489b7f4419f535c991a443345058a8f618574019d5581d3df94fc0339c3a53d4c3147f5e11ca3a11
+EBUILD txaio-20.4.1.ebuild 1252 BLAKE2B ef77351e92559169d9587bde6a393d37d799ee6007c329e5a2845e7c89725edb982db4079f762c222673787871a822659514b36fc0756ec2e8f4bd6205808a13 SHA512 90557e6e7d2670cfb4a609a4cee7395db2ff40d4d2e03bfd322d5d4f1b51b68a0107e1685441cdcc900055740bc5116f9d1d6047e1f643af06d7c4161f38debb
+MISC metadata.xml 492 BLAKE2B 5a30e6aeef4fe8e51cc945db2433d0154cad032923fb596c7723ea85c0e26097a55367c7f7aad898f8e92d7e0bc25cc8e15f846e2e620c956df7918a821c35ba SHA512 789bd30cb7a9467c4fa2b4495294b2c17fc8ac5e62cfe94b44d942e73a4cf76674b65866607c7a6767ceb6ea92f8dbde7dcd2c02b83829d2e82219c6aa5e4c38
diff --git a/dev-python/txaio/metadata.xml b/dev-python/txaio/metadata.xml
index 7a2706920d55..e8669e1d3fa0 100644
--- a/dev-python/txaio/metadata.xml
+++ b/dev-python/txaio/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
</maintainer>
<upstream>
<maintainer>
diff --git a/dev-python/txaio/txaio-20.4.1.ebuild b/dev-python/txaio/txaio-20.4.1.ebuild
new file mode 100644
index 000000000000..f5c3f1f1cd61
--- /dev/null
+++ b/dev-python/txaio/txaio-20.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
+ )
+ test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Take out failing tests known to pass when run manually
+ # we certainly don't need to test "python setup.py sdist" here
+ rm "${S}/test/test_packaging.py" || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ pytest -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}