summaryrefslogtreecommitdiff
path: root/dev-python/txtorcon/txtorcon-23.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
commit39ca6159b9ac903dc56818918d9f97bc831f0955 (patch)
treee9b34845be7f96bc244fd239f6dd8090096ce703 /dev-python/txtorcon/txtorcon-23.5.0.ebuild
parentbc968d15e7f24968eb69567c7f2fca470fdedacd (diff)
gentoo auto-resync : 04:11:2023 - 22:13:37
Diffstat (limited to 'dev-python/txtorcon/txtorcon-23.5.0.ebuild')
-rw-r--r--dev-python/txtorcon/txtorcon-23.5.0.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/dev-python/txtorcon/txtorcon-23.5.0.ebuild b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
index a1f17ef91891..0046315727fb 100644
--- a/dev-python/txtorcon/txtorcon-23.5.0.ebuild
+++ b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
@@ -3,14 +3,21 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
-HOMEPAGE="https://txtorcon.readthedocs.org https://pypi.org/project/txtorcon/"
-SRC_URI="https://github.com/meejah/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://txtorcon.readthedocs.org/
+ https://github.com/meejah/txtorcon/
+ https://pypi.org/project/txtorcon/
+"
+SRC_URI="
+ https://github.com/meejah/txtorcon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -22,12 +29,14 @@ RDEPEND="
dev-python/incremental[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/twisted[ssl,${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
sys-process/lsof
dev-python/mock[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest