summaryrefslogtreecommitdiff
path: root/dev-python/ubelt/ubelt-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/ubelt/ubelt-0.9.4.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/ubelt/ubelt-0.9.4.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.9.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-0.9.4.ebuild b/dev-python/ubelt/ubelt-0.9.4.ebuild
new file mode 100644
index 000000000000..1505cc0f7ac7
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # relies on passwd being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } tests ||
+ die "Tests fail with ${EPYTHON}"
+}