summaryrefslogtreecommitdiff
path: root/dev-python/ujson/ujson-1.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ujson/ujson-1.35.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ujson/ujson-1.35.ebuild')
-rw-r--r--dev-python/ujson/ujson-1.35.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/ujson/ujson-1.35.ebuild b/dev-python/ujson/ujson-1.35.ebuild
new file mode 100644
index 000000000000..f09734949f28
--- /dev/null
+++ b/dev-python/ujson/ujson-1.35.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sort_keys-segfault.patch"
+ "${FILESDIR}/${P}-use-static-where-possible.patch"
+ "${FILESDIR}/${P}-fix-for-overflowing-long.patch"
+ "${FILESDIR}/${P}-standard-handling-of-none.patch"
+ "${FILESDIR}/${P}-fix-ordering-of-orderdict.patch"
+ "${FILESDIR}/${P}-test-depricationwarning.patch"
+)
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die
+}