summaryrefslogtreecommitdiff
path: root/dev-python/unasync/unasync-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/unasync/unasync-0.5.0.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/unasync/unasync-0.5.0.ebuild')
-rw-r--r--dev-python/unasync/unasync-0.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/unasync/unasync-0.5.0.ebuild b/dev-python/unasync/unasync-0.5.0.ebuild
new file mode 100644
index 000000000000..2d1854f67f00
--- /dev/null
+++ b/dev-python/unasync/unasync-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The async transformation code."
+HOMEPAGE="https://github.com/python-trio/unasync"
+SRC_URI="https://github.com/python-trio/unasync/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ # Stop test from breaking itself
+ sed -i 's/\(env\["PYTHONPATH"\] = os.path.realpath(os.path.join(TEST_DIR, ".."))\)/#\1/' "${S}/tests/test_unasync.py" || die
+ default_src_prepare
+}
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest