summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
commitc4b414ba84991b36b62c066b701385eaf44cdd49 (patch)
tree5cbdb7a51f1abb965fdfe90b686f8130e100afaa /dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
parentea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (diff)
gentoo auto-resync : 31:12:2022 - 20:20:25
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
new file mode 100644
index 000000000000..93177ac576f4
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="
+ https://pythonhosted.org/uncertainties/
+ https://github.com/lebigot/uncertainties/
+ https://pypi.org/project/uncertainties/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc --no-autodoc
+
+src_prepare() {
+ # not used in py3, see https://github.com/lebigot/uncertainties/pull/168
+ sed -i -e '/future/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "numpy support" dev-python/numpy
+}