summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties/uncertainties-3.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/uncertainties/uncertainties-3.1.7.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.7.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.7.ebuild b/dev-python/uncertainties/uncertainties-3.1.7.ebuild
new file mode 100644
index 000000000000..6a0cd2fa7e53
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc --no-autodoc
+
+pkg_postinst() {
+ optfeature "numpy support" dev-python/numpy
+}