summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
commit77b275a53383b07b154caa09feb6f4961b206638 (patch)
treebf2b88f1f848dfe69541c3d78aaa35ef22560107 /dev-python/uncertainties
parent9d4810f84de876ec9d0ae03d0d44224500b41188 (diff)
gentoo auto-resync : 20:05:2024 - 00:02:15
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest4
-rw-r--r--dev-python/uncertainties/metadata.xml2
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild10
3 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index acfd83e5aa30..2d6338b1184d 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1,3 +1,3 @@
DIST uncertainties-3.1.7.tar.gz 158727 BLAKE2B d68b74d291b1f6c4505a47f6fa19653eade43dc1ccaf78e02bd320df92d8bdaeac1b0808a21dceb046a6e2acd076836728b4014d39ca8da17647582320ce50e8 SHA512 24576415265df22459d83bb28e632195e6760204a6e11523821afe25222ea3e035bf7f10c552ec456bb2cdf42a09e296865f9bf0d13ff44beb88c11ebc479ff9
-EBUILD uncertainties-3.1.7-r1.ebuild 849 BLAKE2B 725486b092d6edd0510708662e3e72bec6d279a5e0a3798b818f4ce8190121e7a4371e3c4829dbb68cdf9bb4378533f53b9f64eba41a59656b7dd244d50fccd2 SHA512 b8148f42f6e3e1bf5f76fd6fbc4757cbee6add392493e1f03a886a654b06fccdd37218d849de5afb18d54cb297a4f01fa8185d4e7e7950f058434e6d6ba11d03
-MISC metadata.xml 1030 BLAKE2B 7f3e44920c1d05ca25974f1167804d21e0280221ba73b07a759284f7fdd77b62a02037df2275d6a7709ea37113b78fb0fb2034c99e7247dd55262176125451e2 SHA512 961c7fc2f96b9ea0694fd6283f1ba54903c500f2d78c00957f908ba369ecbd7850c429e12bb35ec29b07ff807ae648ba1b37e2b6b82b5c9cb9935badafdc76ec
+EBUILD uncertainties-3.1.7-r1.ebuild 1019 BLAKE2B 8d1117d59ed46327d78010853620c8462e592f430fd9bf08e1e7e732bba82566bf56b33cabc2b40a567e5533f5dc98715dd65db9015d1c2d5a6ff3b2807dcc0c SHA512 c3e3d0c1b44106d617e5397c8acf22ef4543c35346cd313d147134673f16ff5b95abe1567027310c7f8af4359f813a8b0d33e9eeb06e858d998dbb99d49e4f04
+MISC metadata.xml 1028 BLAKE2B 26cc84a3791d81a939512fd405771c70fc606cddef64c1c47c5dbf8d0e0c390cd1cbda4d686903a146acd493c5b46018053eb42bff6a6c4abb29be12ff20ad9c SHA512 59d8a58dff2111ea9d58591ffbfc13fc0521e8234fc6a2478984b6e496f0b718eff5adea25202d1d4b2ac2d1bd46812fcc7fb4779e966e800a51d4824fef6d28
diff --git a/dev-python/uncertainties/metadata.xml b/dev-python/uncertainties/metadata.xml
index 86cdd1f286cc..4d1857508b13 100644
--- a/dev-python/uncertainties/metadata.xml
+++ b/dev-python/uncertainties/metadata.xml
@@ -21,7 +21,7 @@
are what is predicted by error propagation theory.
</longdescription>
<upstream>
- <remote-id type="github">lebigot/uncertainties</remote-id>
+ <remote-id type="github">lmfit/uncertainties</remote-id>
<remote-id type="pypi">uncertainties</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
index 5c1abc030534..d959694cae67 100644
--- a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ inherit distutils-r1 optfeature pypi
DESCRIPTION="Python module for calculations with uncertainties"
HOMEPAGE="
https://pythonhosted.org/uncertainties/
- https://github.com/lebigot/uncertainties/
+ https://github.com/lmfit/uncertainties/
https://pypi.org/project/uncertainties/
"
@@ -29,8 +29,12 @@ distutils_enable_tests pytest
distutils_enable_sphinx doc --no-autodoc
src_prepare() {
- # not used in py3, see https://github.com/lebigot/uncertainties/pull/168
+ # not used in py3, see https://github.com/lmfit/uncertainties/pull/168
sed -i -e '/future/d' setup.py || die
+ # fix tests with numpy-2
+ # https://github.com/lmfit/uncertainties/pull/225
+ sed -e "/assert not hasattr(numpy, 'acos')/d" \
+ -i uncertainties/unumpy/test_unumpy.py || die
distutils-r1_src_prepare
}